What did you do to your NNBS GMT900 Tahoe/Yukon Today?

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Geoffsfas10

Full Access Member
Joined
Nov 27, 2019
Posts
751
Reaction score
1,613
Location
St. Louis
sounds external to me, take off the ac belt and try again.

I know...it does but it doesnt. its 100% is coming from the front of the engine, just hard to pin point. was also thinking of just taking the belt off and manually spinning the pullies to see if any squeal. ive had them go bad before but they sounded more like blower noise then this
 

Geoffsfas10

Full Access Member
Joined
Nov 27, 2019
Posts
751
Reaction score
1,613
Location
St. Louis
That doesn't sound internal to me. Any chance the flywheel is cracked and is hitting randomly?
pretty sure the bendix in the starter is broken and that casuing a secondary noise/tick. whole thing is a mess haha

im gonna take the belt off tomorrow when its cold, since the water pump wont be driven, and see what sounds it makes. its a little too warm here for my liking to run it without water
 

Doubeleive

Wes
Supporting Member
Joined
Nov 7, 2017
Posts
23,038
Reaction score
33,430
Location
Stockton, Ca.
pretty sure the bendix in the starter is broken and that casuing a secondary noise/tick. whole thing is a mess haha

im gonna take the belt off tomorrow when its cold, since the water pump wont be driven, and see what sounds it makes. its a little too warm here for my liking to run it without water
take off both belts then, I have had ac pumps sound almost identical to that and much worse.
 

Doubeleive

Wes
Supporting Member
Joined
Nov 7, 2017
Posts
23,038
Reaction score
33,430
Location
Stockton, Ca.
in that case lisle makes a tool for getting it off and on, getting it off is easy, getting it back on is a little trickier you have to place the tool in just the right spot because of the plastic or metal piece that goes over the balancer
I have seen it done with a screw driver on youtube

Lisle 59370​

 

Forum statistics

Threads
128,349
Posts
1,797,888
Members
91,138
Latest member
jonlwold

Latest posts

Top