Tahoe stalls when warm

Jim Adler

TYF Newbie
Joined
Jun 17, 2021
Posts
24
Reaction score
13
as pmw stated really need to figure what you lose when it dies any of the above stated are possible. fuel pump is going bad but only dies when it warms up. coil packs are going bad and stop working once they warm up. could even just be the fuel pump relay gives up when it warms up.
I’m gonna check the relay and use that fuel pump gauge.
 

Jim Adler

TYF Newbie
Joined
Jun 17, 2021
Posts
24
Reaction score
13
Welcome to the Forum from NH.

Lots of knowledgeable folks here who freely share their knowledge, experiences, and perspectives. Knowledge is power.

I hope that you will become a participating member in the Forum's discussions.

Pics, please.

You are already receiving suggestions from the knowledgeable folks on this Forum, and others will chime in. It makes total sense to rent a gas pressure gauge, and then you can either confirm or remove the fuel pressure question out of the equation for your troubleshooting.
What kind of pics should I add?
 

PNW VietVet

CCW
Supporting Member
Joined
Oct 8, 2014
Posts
9,893
Reaction score
10,433
Location
Oregon
Now we are getting somewhere. This is a load condition/temp problem. Now for a fuel pressure reading, especially with long hose and see what happens when driving.
 

Jim Adler

TYF Newbie
Joined
Jun 17, 2021
Posts
24
Reaction score
13
You must be logged in to see this image or video!
 

Attachments

  • E2A598F6-BADB-4856-873D-2CD56A7C00FF.jpeg
    E2A598F6-BADB-4856-873D-2CD56A7C00FF.jpeg
    314.4 KB · Views: 3
  • 33C9CA55-485F-4985-B67B-CFAEDC5AC28E.jpeg
    33C9CA55-485F-4985-B67B-CFAEDC5AC28E.jpeg
    265.3 KB · Views: 3

Jim Adler

TYF Newbie
Joined
Jun 17, 2021
Posts
24
Reaction score
13
There’s my truck. Sorry, I had some business to attend to. Back at it today and now because it’s been sitting for about a month the battery was kinda drained when I tried to start it today. All the power is dead and it seems like a bad ground somewhere cuz it won’t allow me to even jump start it. Every time I try to hook it up the jump starter goes into an error mode meaning there’s a bad connection somewhere. Could this be a separate issue or the root of the problem? Either way I gotta figure it out
 

Fless

Supporting Member
Joined
Apr 2, 2017
Posts
4,056
Reaction score
6,706
Location
Elev 5,280
If your battery voltage is too low many chargers won't even try. Get a new battery or take it somewhere that has a charger that can handle it.
 

Jim Adler

TYF Newbie
Joined
Jun 17, 2021
Posts
24
Reaction score
13
If your battery voltage is too low many chargers won't even try. Get a new battery or take it somewhere that has a charger that can handle it.
That’s exactly what I was thinking. I’ve already got it unhooked and waiting for my ride to take me up to Oreily real quick.
 

Forum statistics

Threads
113,148
Posts
1,538,125
Members
69,801
Latest member
mandop86

Latest posts

Top