Oil pressure low

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Mfitz725

TYF Newbie
Joined
May 12, 2023
Posts
10
Reaction score
12
Hi! 05 Tahoe 5.3L. Installed pick up tube o-ring. On initial startup seemed to have fixed the problem. However, after running for a few minutes got oil pressure low again. Where should I go from here? I'm relatively new to Tahoe/GM products and haven't a clue as to where to go next. Any help would be greatly appreciated.
 

OR VietVet

Multnomah Falls
Supporting Member
Military
Joined
Oct 8, 2014
Posts
19,246
Reaction score
31,672
Location
Willamette Valley
Help us first. What exactly is the "low" oil pressure reading at cold start, idling as warming up, idling after warm, rev engine in park, driving and when accelerate? Have you attached a scanner for readings or a pressure gauge? You may have great pressure and wrong readings.
 

Fless

Staff member
Super Moderator
Joined
Apr 2, 2017
Posts
10,462
Reaction score
20,778
Location
Elev 5,280
Help us first. What exactly is the "low" oil pressure reading at cold start, idling as warming up, idling after warm, rev engine in park, driving and when accelerate? Have you attached a scanner for readings or a pressure gauge? You may have great pressure and wrong readings.

I'd be surprised to find an oil pressure PID in an NBS. Prove me wrong, please, or at least surprise me!
 
OP
OP
M

Mfitz725

TYF Newbie
Joined
May 12, 2023
Posts
10
Reaction score
12
Help us first. What exactly is the "low" oil pressure reading at cold start, idling as warming up, idling after warm, rev engine in park, driving and when accelerate? Have you attached a scanner for readings or a pressure gauge? You may have great pressure and wrong readings.
Thank you for responding. I came across a post regarding my issue, changed to an A/C Delco filter and the problem was solved.
 

Marky Dissod

Full Access Member
Joined
Mar 3, 2023
Posts
1,176
Reaction score
1,523
Location
(718)-
Thank you for responding. I came across a post regarding my issue, changed to an A/C Delco filter and the problem was solved.
would you share what oil filter you were using that caused this low oil pressure?
Or at least share the post / thread that addressed this issue?
 
OP
OP
M

Mfitz725

TYF Newbie
Joined
May 12, 2023
Posts
10
Reaction score
12
Thank you for responding. I came across a post regarding my issue, changed to an A/C Delco filter and the problem was solved.
Well I guess I spoke too soon.

Cold start pressure seems OK but as soon as it warms up low oil pressure warning comes on below 1200 rpm. As soon as I pass the I200 rpm mark pressure goes up and warning stops. I switched to a 10w 40 oil and tried adding a Lucas oil treatment to no avail. Can someone point me in a direction?
 

Forum statistics

Threads
129,203
Posts
1,812,071
Members
92,305
Latest member
DefiantOne
Top