1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Randeez 2012 Yukon Denali

Discussion in 'Under Construction' started by randeez, Sep 29, 2017.

  1. 07Burb

    07Burb GM fan for life Staff Member Administrator Supporting Member

    Posts:
    42,617
    Likes Received:
    7,960
    Joined:
    Jan 3, 2011
    Name:
    Jacob
    Hey man. I'm a little late but welcome to TYF. I know you from the Nuggetry on FSC:wave:
     
    Last edited: Oct 23, 2017
    randeez likes this.
  2. randeez

    randeez Full Access Member

    Posts:
    1,617
    Likes Received:
    3,481
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    Rained most of the day today, took it easy. Everything went together pretty smooth had a couple times I had to 2x check a few things with the cam. I just pushed tensioner back, pinned it, and worked chain off cam gear- was easy enough. Going back on however was a PITA, in hindsight it probably would have been easier to pull oil pump and work both. Alignment pin from cam to gear also pain, ended up having to put a few wraps of tape old cam bolt threads so I could spin cam behind gear to get it to line up. It all worked but would have been easier to mount gear to cam and install.
    All I could find was BS valve spring tool that resembles a cork screw, it worked but will invest in either big c-clamp style or ls style before I do another set of valve springs.
    Alas it is back together will try and get back in truck tomorrow, probably take a couple days to get all the little stuff mounted back up

    20171022_223006.jpg
     
  3. inmypassatlife

    inmypassatlife Full Access Member

    Posts:
    980
    Likes Received:
    671
    Joined:
    Feb 21, 2017
    Name:
    Nan Doh!
    It's not fwd, you're doing it wrong! Lol
     
  4. randeez

    randeez Full Access Member

    Posts:
    1,617
    Likes Received:
    3,481
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    Lol, I came across a couple posts saying to turn it sideways, didn't really think anything of it, tried to pull it straight out and it wasn't looking good. lowered it back down and turned and it came right out!
     
  5. randeez

    randeez Full Access Member

    Posts:
    1,617
    Likes Received:
    3,481
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    It's getting there. 20171024_194355.jpg 20171023_182459.jpg 20171024_194347.jpg
     
    Sam Harris, Miami-Dade and kwOH like this.
  6. 07Burb

    07Burb GM fan for life Staff Member Administrator Supporting Member

    Posts:
    42,617
    Likes Received:
    7,960
    Joined:
    Jan 3, 2011
    Name:
    Jacob
    ivin74 and Miami-Dade like this.
  7. randeez

    randeez Full Access Member

    Posts:
    1,617
    Likes Received:
    3,481
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    Hey i've seen the pace of some of the build threads around here gimme a break :321:

    thought i was getting rained out again this afternoon, was mostly just organizing tools and cleaning up...mounted the 40k tru cool and decided just to throw it in, now all the hard work begins trying to remember where every bolt goes. went back in without much trouble and got bellhousing bolts all in
     
  8. kwOH

    kwOH Banned

    Age:
    28
    Posts:
    2,960
    Likes Received:
    3,512
    Joined:
    Jun 19, 2016
    Name:
    Kenny
    Not sure whats going on here but it looks badass...
     
    randeez likes this.
  9. randeez

    randeez Full Access Member

    Posts:
    1,617
    Likes Received:
    3,481
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    cam stall longtube tune denali! mechanically deleted the AFM/DOD- kept the VVT , replaced lifters, pushrods, springs, and installed the VVT limiter. Reassembled with headstuds and ls9 gaskets in case i get an itch for some boost later on, probably overkill but had to replace them anyway

    and it is soooo close. But ran into a little issue, header on the driver side hits the mounting tab for the front axle and the o2 sensor bung is pointed at the front driveshaft. A new engine mount may fix it, I only had a little flat prybar to try and coax it away from the mount, bigger prybar is at my office and will prob come home to take care of it. Passenger side fit good, just dont remember where o2 sensor was on it, but that side is pretty clear shouldnt be an issue wherever it is.
    ran most of the wiring harness back and plugged everything i could in.
    only things left are:

    fix the header, may throw a couple washers under the motor mount for temp
    put the coils on driver side
    put spark plugs back in
    mount the bracket for alt/power steering pump
    put the fans back in
    find the stupid e clip for the oil cooler line and hook them back to radiator
    change transmission filter and top off, check for any leaks with new cooler
    finish exhaust y-pipe
    fill coolant and oil
    load the tune from black bear
    put the front end back together if it actually runs
     
    Sam Harris, Miami-Dade and kwOH like this.
  10. randeez

    randeez Full Access Member

    Posts:
    1,617
    Likes Received:
    3,481
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    20171025_205649.jpg 20171025_205605.jpg 20171025_205610.jpg 20171025_205625.jpg
     
    Sam Harris, Miami-Dade and kwOH like this.

Share This Page