no brake lights or 3rd brake light

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

brianarmstrong

TYF Newbie
Joined
Jan 9, 2023
Posts
3
Reaction score
6
I have a 2013 yukon I have no brake lights or high centre light in rear The cruze control works as it should and I can shut it off with the foot pedal The turn signals and 4 ways work fine ,I suspect the white wire from brake light switch to the turn signal switch is defective any thoughts on this
 

Joseph Garcia

Supporting Member
Joined
Aug 2, 2018
Posts
6,743
Reaction score
8,897
Welcome to the Forum from NH.

Lots of knowledgeable folks here who freely share their knowledge, experiences, and perspectives. Knowledge is power.

I hope that you will become a participating member in the Forum's discussions.

Pics of the truck, please.

Have you checked the fuses?

What voltage ate you getting at the brake switch output, when the brake pedal is depressed?
 

Fless

Staff member
Super Moderator
Joined
Apr 2, 2017
Posts
10,859
Reaction score
21,656
Location
Elev 5,280
Moved this thread here from the 2021+ section.
 
Joined
Apr 11, 2018
Posts
6,610
Reaction score
13,016
Location
St. Louis
Has the light outage been confirmed while the vehicle is running and not just parked? The brake lights won't come on unless the vehicle is running
 

Forum statistics

Threads
130,118
Posts
1,826,691
Members
93,598
Latest member
04 Z71 learning
Top