Crazy stuff

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Rob Yukon

Member
Joined
Jan 28, 2024
Posts
39
Reaction score
8
My 2000 GMC Yukon Denali wouldn’t start this morning. I had pumped the gas 3 times like my neighbor said, and no start. So I came home from work and did what I’ve been doing and cranked it twice and it fired right up. I don’t know why I have to crank it twice but I do. After I start it it will start right up. It only does it after it sits overnight or after it sitting all day at work. Weird right
 

Marky Dissod

Full Access Member
Joined
Mar 3, 2023
Posts
1,153
Reaction score
1,488
Location
(718)-
My 2000 GMC Yukon Denali wouldn’t start this morning.
I had pumped the gas 3 times like my neighbor said, and no start.
So I came home from work and did what I’ve been doing and cranked it twice and it fired right up.
I don’t know why I have to crank it twice but I do. After I start it it will start right up.
It only does it after it sits overnight or after it sitting all day at work. Weird right?
Instead of cranking twice, or pumping the gaspedal 3x,
Turn the key to the On-Run position without starting it, and wait 3-5sec.
Turn it back away from On-Run, then turn the key to the On-Run position again.
Wait 3-5sec, THEN start it. I bet it starts.

Explain that to a 1/2way decent mechanic.
They SHOULD be able to fix the problem without diagnosing it for several hours.
 
OP
OP
R

Rob Yukon

Member
Joined
Jan 28, 2024
Posts
39
Reaction score
8
Instead of cranking twice, or pumping the gaspedal 3x,
Turn the key to the On-Run position without starting it, and wait 3-5sec.
Turn it back away from On-Run, then turn the key to the On-Run position again.
Wait 3-5sec, THEN start it. I bet it starts.

Explain that to a 1/2way decent mechanic.
They SHOULD be able to fix the problem without diagnosing it for several hours.
I tried that this morning and it worked. Thanks
 

Marky Dissod

Full Access Member
Joined
Mar 3, 2023
Posts
1,153
Reaction score
1,488
Location
(718)-
Note that
Instead of cranking twice, or pumping the gaspedal 3x,
Turn the key to the On-Run position without starting it, and wait 3-5sec.
Turn it back away from On-Run, then turn the key to the On-Run position again.
Wait 3-5sec, THEN start it. I bet it starts.

Explain that to a 1/2way decent mechanic.
They SHOULD be able to fix the problem without diagnosing it for several hours.
I tried that this morning and it worked. Thanks.
Don't forget to explain what's going on to your favorite mech.
It's not like I fixed the problem.
 
Last edited:
Top