2010 Yukon ac problems

Discussion in 'Tech Info' started by Peyton, Jun 2, 2017.

  1. Peyton

    Peyton TYF Newbie

    Posts:
    2
    Likes Received:
    0
    Joined:
    Jun 1, 2017
    Name:
    Peyton
    Hey guys, new to forum, looking for some help, my wife has a 10 Yukon, she has been making comments to me about her air not blowing but I never could find an issue, when she would get home she said it wasn't blowing anything and I would go outside and crank it up and everything was working fine, so I chalked it up to her pregnancy hormones!! Haha but we loaded up yesterday to head to the beach and made it about an hr down the road and I noticed it was kinda warm, turned temp down a little and put my hand on vent and no air was blowing, turned temp all the way down and you can hear blower running but no air coming out any vents, turned it off let it thaw out thinking it was frozen up and sure enough after 10-15 minutes turned back on, blows ice cold, then after while freezes up again, I thought low on freon I will buy one of those el cheapo cans with gauge and gas it up and be done till we get back home and find real issue, stop by Walmart pick one up, get to where we are staying put gauge on it, pressure shows good, not low at all maybe even a little high? Little hesitant to trust cheap gauge and all my tools are 300+ miles away and I have a return drive home Sunday with a 4 year old and a brand new baby! any ideas other than the freon? or how trustworthy I should be of this gauge?? Any help or ideas would be greatly appreciated, I'm pretty mechanically sharp but I know nothing about ac systems

    + QuoteReply
     
  2. 2011SSVHOE

    2011SSVHOE I'm an egual oportunity offender

    Posts:
    1,296
    Likes Received:
    839
    Joined:
    Dec 2, 2016
    Location:
    The Heart of The Triad, North Carolina
    Name:
    ROGER
    maybe a mode door actuator, just a guess
     
  3. yukon702

    yukon702 Member

    Posts:
    51
    Likes Received:
    11
    Joined:
    Jun 9, 2013
    Location:
    Las Vegas
    Name:
    yukon702
    First you should go to AutoZone and rent some ac gauges and see what it is reading off and when turned on. It's free and you can buy cans of refrigerant and charge it up exactly to specs if it is low.
     
  4. Ejbarah

    Ejbarah TYF Newbie

    Posts:
    23
    Likes Received:
    12
    Joined:
    May 16, 2018
    Location:
    kuwait
    Name:
    Ejbarah
    Because you have two issues : No air blowing + Warm Air

    If there is no air blow from vents : Check the blower or blower fan resistor




    If you set the temp setting to cold and the air is warm you may had bad Air temp actuators.
     
  5. Fixxer

    Fixxer TYF Newbie

    Posts:
    3
    Likes Received:
    6
    Joined:
    Jul 20, 2018
    Name:
    Derek
    Might also want to check the cabin air filter. Might be restricting the airflow enough to freeze the evaporator core?
     
  6. gpracer1

    gpracer1 Full Access Member

    Posts:
    782
    Likes Received:
    186
    Joined:
    Jun 16, 2011
    Location:
    Phoenix
    Name:
    Marc
    You only have a cabin air filter if someone bought and installed it, but you say it does blow good at first so I doubt it would be that.....
    If you live in a humid area and are either low on refrigerant or blower is set low, you may be freezing up the evap.
    Wait till it happens again and JUST turn off the AC button and leave it blowing, if it was frozen it will slowly start blowing hard again and you may smell the moisture.
    That could rule out door blend issues.
    You will need gauges to see the pressures to make any sense of what is really going on.
     

Share This Page