2001 GMC Yukon XL

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

AG01YukonXL

TYF Newbie
Joined
Feb 21, 2024
Posts
6
Reaction score
1
Out of nowhere smelled as if something was melting… shortly after power doors would not lock from any of the switches or alarm remote, power mirror would not work… read a few articles, changed the 3 amp fuse, power mirrors now work. Read a few more articles, ck’ d all fuses, relays & all are good. Went to mechanic and advised to change the actuators (all 4) asked what would cause all 4 to go in an instance, mechanic could not give me an answer, stated have to take it step by step … my concern; replace all 4 actuators? If cause is unknown, once replaced bk to square one. Took my truck home, ordered and replaced all 4 actuators, now all power doors unlock from the switches and alarm remote but only the drivers door locks from the switches and alarm remote. Note: when I select unlock on the drivers side switch, passenger side switch and alarm remote I hear the motors unlocking all doors, when I select lock on the drivers side switch, passenger side switch and alarm remote the drivers door locks but I do not hear anything from the other doors… I have not seen any posts or videos with a similar problem… anyone else had or currently having this problem, please chime in… Thanks in advance!
 
Last edited:

Big Mama

Full Access Member
Joined
Jul 21, 2015
Posts
3,133
Reaction score
1,828
Location
Virginia
welcome to the forum from Virginia. Did you or the mechanic check the ground cables? These rigs are known to have problems there. Someone with more knowledge on this than me will chime in.
 
OP
OP
A

AG01YukonXL

TYF Newbie
Joined
Feb 21, 2024
Posts
6
Reaction score
1
welcome to the forum from Virginia. Did you or the mechanic check the ground cables? These rigs are known to have problems there. Someone with more knowledge on this than me will chime in.
Thanks for the reply, yes… my electronics installer ck’d all with a power probe, grounds and power all passing thru to the actuator plugs, advised I try to replace the actuators, which I did but still having the same problem.
 

Big Mama

Full Access Member
Joined
Jul 21, 2015
Posts
3,133
Reaction score
1,828
Location
Virginia
Sorry to hear that. There are tons of guys on here with 800’s. They’ll join in soon.
 

wjburken

Supporting Member
Joined
Dec 26, 2017
Posts
9,841
Reaction score
26,943
Location
Eastern Iowa
Have you had any other work done on your truck prior to this happening?

I am assuming, based solely on your username since you posted no specifics about your vehicle, that you have a 2001 Yukon.

Any aftermarket equipment like security system, stereo, etc?
 

Doubeleive

Wes
Supporting Member
Joined
Nov 7, 2017
Posts
23,976
Reaction score
35,221
Location
Stockton, Ca.
Out of nowhere smelled as if something was melting… shortly after power doors would not lock from any of the switches or alarm remote, power mirror would not work… read a few articles, changed the 3 amp fuse, power mirrors now work. Read a few more articles, ck’ d all fuses, relays & all are good. Went to mechanic and advised to change the actuators (all 4) asked what would cause all 4 to go in an instance, mechanic could not give me an answer, stated have to take it step by step … my concern; replace all 4 actuators? If cause is unknown, once replaced bk to square one. Took my truck home, ordered and replaced all 4 actuators, now all power doors unlock from the switches and alarm remote but only the drivers door locks from the switches and alarm remote. Note: when I select unlock on the drivers side switch, passenger side switch and alarm remote I hear the motors unlocking all doors, when I select lock on the drivers side switch, passenger side switch and alarm remote the drivers door locks but I do not hear anything from the other doors… I have not seen any posts or videos with a similar problem… anyone else had or currently having this problem, please chime in… Thanks in advance!
I would replace both the door lock relays, if that does not work then replace the master door switch, plenty of both in the junkyards
the alarm installer should have checked the relays, which it sounds like he did? but they could be "weak" especially at 20+ years old
 
OP
OP
A

AG01YukonXL

TYF Newbie
Joined
Feb 21, 2024
Posts
6
Reaction score
1
Have you had any other work done on your truck prior to this happening?

I am assuming, based solely on your username since you posted no specifics about your vehicle, that you have a 2001 Yukon.

Any aftermarket equipment like security system, stereo, etc?
Thanks to all for the replies. WJBURKEN, apologies, correct I have a 2001 GMC Yukon XL, 175,000 miles. Note: Drivers door switch previously replaced, ordered another, attached; same problem persists… do have an auto page alarm installed (10+ yrs old), aftermarket sound system, horn & rock lights … all functional.

My installer did test the alarm & replaced the brain when he saw the lock issue, had same model on dusty shelf. Going to try and disconnect the battery to see if that would do anything… reset. Also ordered the super relay buddy to test the relays, even though I swapped them out.

Did also read in an old post here from

Matthew Jeschke with same problem on his 01 Tahoe,​

that he removed a “jumper relay” and found that he replaced it the wrong way… waiting for a reply in that post for clarification / location as I don’t see anything labeled jumper relay in diagrams.
 
OP
OP
A

AG01YukonXL

TYF Newbie
Joined
Feb 21, 2024
Posts
6
Reaction score
1
Prior work:
Transmission replaced 4 yrs ago, bk at 130,000 miles.
All fuel lines replaced last year.
Sound system upgraded 5 years ago.
TV monitors on the headrests & visors installed 7+ years ago.
Rock lights installed 2 yrs ago.
Heavy duty optima battery installed last year.
Replaced all door actuators over past week.

No other problems or work done to the truck, runs as if driven out of the dealer yesterday… with the exception of my power door lock issue.
 

Fless

Staff member
Super Moderator
Joined
Apr 2, 2017
Posts
10,611
Reaction score
21,131
Location
Elev 5,280
Thanks to all for the replies. WJBURKEN, apologies, correct I have a 2001 GMC Yukon XL, 175,000 miles.

Did also read in an old post here from

Matthew Jeschke with same problem on his 01 Tahoe,​


Free Tip Sunday: if you want to "tag" someone, either quote that person's post (like I did here), or use the "@" symbol and start typing the user's name. Then pick the correct one from the picklist of users. Finish typing your message.

If you don't do either one of those, your target won't be a sure hit.
 

wjburken

Supporting Member
Joined
Dec 26, 2017
Posts
9,841
Reaction score
26,943
Location
Eastern Iowa
Did also read in an old post here from

Matthew Jeschke with same problem on his 01 Tahoe,​

that he removed a “jumper relay” and found that he replaced it the wrong way… waiting for a reply in that post for clarification / location as I don’t see anything labeled jumper relay in diagrams.
I’m pretty sure he did his best to describe the relay he was referring to for you yesterday. Might take a peak at that post.
Free Tip Sunday
What? You’re giving out Free Tips now? What has this forum come to.
 

Forum statistics

Threads
129,626
Posts
1,819,130
Members
92,915
Latest member
PeterF
Top