Service Suspension Soon 2010 Yukon Denali

Discussion in 'Street Suspension' started by Stimpy911, Oct 9, 2018.

Sponsored By: DJM Belltech
  1. Stimpy911

    Stimpy911 Member

    Posts:
    59
    Likes Received:
    6
    Joined:
    Jul 7, 2016
    Name:
    Steven
    I have been getting the service suspension warning but only have a longer trip. Last time the message came on was during a couple hundred mile trip. Around town the warning does not come on.

    Any ideas as to what could be wrong?

    Thanks,

    Steve

    2010 Yukon Denali XL
     
  2. Big Mama

    Big Mama Full Access Member

    Posts:
    800
    Likes Received:
    249
    Joined:
    Jul 21, 2015
    Location:
    Virginia
    Name:
    Steven
    Check connections at all corners they get crud in them.
     
  3. Stimpy911

    Stimpy911 Member

    Posts:
    59
    Likes Received:
    6
    Joined:
    Jul 7, 2016
    Name:
    Steven
    These are the ones behind the tires? Can I use brake cleaner to clean them up?
     
  4. Doubeleive

    Doubeleive Supporting Member

    Posts:
    4,887
    Likes Received:
    3,383
    Joined:
    Nov 7, 2017
    Location:
    Stockton, Ca.
    Name:
    Wes
    I would check the sensors on the shocks and abs, and I would use maf cleaner or electronics cleaner so it wont leave any residue
     
  5. Stimpy911

    Stimpy911 Member

    Posts:
    59
    Likes Received:
    6
    Joined:
    Jul 7, 2016
    Name:
    Steven
    Thank you
     
    Big Mama likes this.
  6. Big Mama

    Big Mama Full Access Member

    Posts:
    800
    Likes Received:
    249
    Joined:
    Jul 21, 2015
    Location:
    Virginia
    Name:
    Steven
    Let us know how it goes. There seems to be more of these lately. It may just be that it’s time for us with gmt900 to watch for them.
     
  7. 97audia4

    97audia4 Full Access Member

    Posts:
    116
    Likes Received:
    112
    Joined:
    Jun 19, 2018
    Name:
    Jeff
    I used the remote start to let it idle today, because its getting cold in Pa and the message was on the display but no other lights on and went away and didnt come back
     

Share This Page