Power Steering Loss - help!

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

2001 TX Tahoe

Member
Joined
Aug 22, 2014
Posts
37
Reaction score
13
2016 Yukon XL 4WD, 87k miles. Dash message came on saying “Service Power Steering, Drive with Care” and I lost all power steering assist. I can still steer (with LOTS of effort), and everything else seems to be fine. No other noticeable issues. Anyone have thoughts on what could be causing this?
 

LordWayback

Full Access Member
Joined
Jun 23, 2022
Posts
478
Reaction score
390
2016 Yukon XL 4WD, 87k miles. Dash message came on saying “Service Power Steering, Drive with Care” and I lost all power steering assist. I can still steer (with LOTS of effort), and everything else seems to be fine. No other noticeable issues. Anyone have thoughts on what could be causing this?
You have electric power steering* most likely what tends to happen is you either have the known steering gear / rack issue or you could have a bad ground if the ground isn’t corroded it might be the actual ground cable , another person can chime in and correct my part number but i believe it’s universal for 2014-2018 GM trucks/SUV’s
AC Delco :

ACDelco Battery Cable - 84634113​

 

LordWayback

Full Access Member
Joined
Jun 23, 2022
Posts
478
Reaction score
390
2016 Yukon XL 4WD, 87k miles. Dash message came on saying “Service Power Steering, Drive with Care” and I lost all power steering assist. I can still steer (with LOTS of effort), and everything else seems to be fine. No other noticeable issues. Anyone have thoughts on what could be causing this?

Technical service bulletin on your Yukon XL and every GM truck/suv in the era it should show you in detail the only thing you can probably do without a mechanic
 

LordWayback

Full Access Member
Joined
Jun 23, 2022
Posts
478
Reaction score
390
2016 Yukon XL 4WD, 87k miles. Dash message came on saying “Service Power Steering, Drive with Care” and I lost all power steering assist. I can still steer (with LOTS of effort), and everything else seems to be fine. No other noticeable issues. Anyone have thoughts on what could be causing this?
Oh and if you read it and attempt it there’s a major difference between inch pounds and ft lbs the TSB says both
 

Dsullivan

TYF Newbie
Joined
Jul 3, 2023
Posts
2
Reaction score
0
Oh and if you read it and attempt it there’s a major difference between inch pounds and ft lbs the TSB says b
2016 Yukon XL 4WD, 87k miles. Dash message came on saying “Service Power Steering, Drive with Care” and I lost all power steering assist. I can still steer (with LOTS of effort), and everything else seems to be fine. No other noticeable issues. Anyone have thoughts on what could be causing this?

I am having the same issue with my 2016 Tahoe LTZ with only 24K miles on it, I was going down the road and got the "Service Power Steering" and lost my power steering with no other issues. Were you able to figure out what your issue was? Thanks
 

hasan632

TYF Newbie
Joined
May 22, 2020
Posts
10
Reaction score
5
Location
Jubail Industrial City; KSA
Hello everyone.
I’ve the same problem in my 2016 Denali xl. The mechanic asked to replace the battery. I got it checked. It has to be replaced. However the problem didn’t go even after replacing it. After reading the posts, I’m assuming it is one of the cables.

Did you manage to get rid of it? I’ve observed that the message comes every time the battery voltage indicator going lower than 14v. The message appears and the power assist totally fails. Please let me know how you have fixed it and where could you on point the root cause.
Thanks alot,
Best regards,
 

Forum statistics

Threads
128,346
Posts
1,797,797
Members
91,126
Latest member
ofarah11
Top