Just bought a 2007 Yukon XL Denali

Discussion in 'General Discussion' started by brodown, Aug 28, 2019.

  1. brodown

    brodown TYF Newbie

    Posts:
    4
    Likes Received:
    7
    Joined:
    Aug 28, 2019
    Name:
    ryan
    As the title states, I am the new owner of this 168k mileage beast. It was a one owner truck, majority of work done by the dealer via carfax. The car runs great- no weird sounds or anything.

    The oil pressure is a bit low, it will idle around 15-20 psi, and then rise to around 40 psi during driving, has not gone to zero- has no warning or CEL lights. I have been reading a LOT of posts about this and I will bring this up to my mechanic tomorrow when I get the truck looked over, and get all the fluids/filters replaced. I have noticed that it will "clunk" sometimes when slowing down, around 1st or second gear. When driving at slow speeds, the transmission will sometimes jump between 2-3, feels like it has trouble deciding which gear to go to, is this common?

    I did call the dealer service department that did all the work on it over its life, and the technician who apparently worked primarily on the vehicle, told me that the engine had a spun bearing and would need a total engine replacement. I find this hard to believe because the truck runs GREAT! Tons of power, no "spun bearing sounds" based on youtube videos. Getting her checked out tomorrow so hopefully everything goes fine!

    IMG_4518.JPG IMG_4543.jpg View attachment 229506 View attachment 229507
     
  2. avalonandl

    avalonandl Full Access Member

    Posts:
    322
    Likes Received:
    270
    Joined:
    Apr 6, 2019
    Location:
    Troy, MICH & Naples, FL
    Name:
    roger
    Trans rebuild in your future.

    Congrats,
     
  3. gooffeyguy

    gooffeyguy Full Access Member

    Posts:
    977
    Likes Received:
    969
    Joined:
    Apr 11, 2018
    Location:
    St. Louis
    Name:
    Tom
    There's a screen under the oil pressure sensor that gets dirty/gunky and causes low pressure readings at idle.

    2001 Yukon SLT
    2012 Yukon Denali XL
    2011 Yukon Denali RIP 5/20/18
     
    Big Mama likes this.
  4. 08HoeCD

    08HoeCD "Prolly" is not a real word

    Posts:
    2,050
    Likes Received:
    1,911
    Joined:
    May 6, 2016
    Name:
    DJ
     
    Galante likes this.
  5. Big Mama

    Big Mama Full Access Member

    Posts:
    1,499
    Likes Received:
    529
    Joined:
    Jul 21, 2015
    Location:
    Virginia
    Name:
    Steven
    Congrats I have the same rig but not xl. If you hear the clunk coming from the back when you let off then pick up that’s usually the limited slip rear on these AWD rigs. Changing the fluid and ensuring you use the conditioner helps. Higher grade fluid like Amsoil is even better. If the carfax didn’t bring up the heated washer fluid recall do that too. There’s a fire hazard there. I bought mine at a dealer and they didn’t do it so I did and got $100 to boot. Good luck.
     
  6. brodown

    brodown TYF Newbie

    Posts:
    4
    Likes Received:
    7
    Joined:
    Aug 28, 2019
    Name:
    ryan
    Thanks- I am hoping the dirty screen/oil pump pickup ring is the cause, and that will be that.. BUT, worse case scenario: what does a "spun bearing" sound like? I am assuming the engine would be behaving differently? Is there any indication of this besides oil pressure sitting where mine is?
     
  7. 08grey

    08grey Supporting Member

    Posts:
    4,411
    Likes Received:
    534
    Joined:
    Jun 17, 2012
    Name:
    joe
    Read up on oil pick up tube gasket.

    Sent from my SM-G973U1 using Tapatalk
     
    Big Mama likes this.
  8. Joseph Garcia

    Joseph Garcia Full Access Member

    Posts:
    307
    Likes Received:
    182
    Joined:
    Aug 2, 2018
    Name:
    Joseph
    Welcome!! You and I have identical-looking trucks.

    I wish you a long and happy union with the truck
     
  9. brodown

    brodown TYF Newbie

    Posts:
    4
    Likes Received:
    7
    Joined:
    Aug 28, 2019
    Name:
    ryan
    Thanks, your truck looks great!

    So the mechanic gave her a once over, told me that the truck looks great for its age. May have a small exhaust leak based on sound coming from engine, but nothing really to worry about. The engine was definitely taken out at one point and worked on, but he drove it and said it felt fine.

    Let's hope this baby lasts!
     
  10. thompsoj22

    thompsoj22 Supporting Member

    Posts:
    376
    Likes Received:
    288
    Joined:
    Jul 21, 2018
    Location:
    california native "REPUBLICAN" high desert
    Name:
    john

    I just did the oil change on our 2008 yukon denali XL-1500 AWD and it has the fly weight limited slip design "no clutches". did they use more than one configueration?

    To the OP, Congrats! you will love your new to you yukon. Ask the mech how he determined a spun bearing? does the oil pan appear to have been removed? worst case scenario you need a reman 6.2 longblock and down the road you go! Hang in there.
     

Share This Page