Clicking sound from blower?

Discussion in 'Interior' started by warndogg, May 13, 2018.

  1. warndogg

    warndogg Member

    Posts:
    45
    Likes Received:
    2
    Joined:
    Mar 14, 2015
    Name:
    justin
    Ok so one day last week I turned the Denali off took the key out and my blower for the HVAC was still blowing. Fast forward to yesterday when I replaced the Blower Resistor with the GM update one...fixed my original problem but now there is a slow clicking coming from the behind my glove box. The clicking is always the same no matter fan speed. And I think it goes away on high. I thought it might need a HVAC system reset so I did that twice but still have this clicking. Any thoughts? It's driving me crazy.
     
  2. M1Gunner

    M1Gunner Full Access Member

    Posts:
    1,018
    Likes Received:
    1,105
    Joined:
    Feb 7, 2015
    Location:
    Gainesville, Fl
    Name:
    Jason
    Can you be more descriptive on the clicking? And if it’s set to full cold a/c raise the temp a couple/few notches and see if the clicking stops.
     
  3. warndogg

    warndogg Member

    Posts:
    45
    Likes Received:
    2
    Joined:
    Mar 14, 2015
    Name:
    justin
    The clicks are steady at about 2 per second. The sound is coming from the blower fan area as far as I can tell. At first I thought it was the fan but it dosen't follow the fan speed. It sounds maybe like a gear? plastic on plastic which is why I thought to reset hvac thinking something was off with a vent door. I will try messing with raising the temp while full a/c is on when I get home later today. As far as I could tell the sound goes away when fan speed is on high. (Either that or I just cant hear it because of the fan noise).
     
  4. warndogg

    warndogg Member

    Posts:
    45
    Likes Received:
    2
    Joined:
    Mar 14, 2015
    Name:
    justin
    No matter what temp or setting climate control is on I have the sound. I dropped the glove box door and put my hand on the heat/ac box or whatever is right behind it and can feel the vibration. I think it might be the blower fan motor. The wife had to use the denali to take the kids to swim lessons. Ill drop the fan tomorrow and take a look.
     
  5. M1Gunner

    M1Gunner Full Access Member

    Posts:
    1,018
    Likes Received:
    1,105
    Joined:
    Feb 7, 2015
    Location:
    Gainesville, Fl
    Name:
    Jason
    more Than likely it’ll be one of the actuators. Ruled out the climate so either recirc/fresh air, mode etc
     
    swathdiver likes this.
  6. warndogg

    warndogg Member

    Posts:
    45
    Likes Received:
    2
    Joined:
    Mar 14, 2015
    Name:
    justin
    It was my blower motor. I pulled it out and it looks clean but it has a bad wobble to it like something is throwing off balance internally. Guess I'm gonna replace that any suggestion on brands? I am seeing prices from $35 to almost $100.
     
  7. warndogg

    warndogg Member

    Posts:
    45
    Likes Received:
    2
    Joined:
    Mar 14, 2015
    Name:
    justin
    Sorry to keep bugging you M1Gunner. I'm thinking.. not sure but I never had this problem until I replaced the resistor. Could the resistor possibly be the cause of the fan wobble? like it's giving off a weird ohm to the motor?
     
  8. M1Gunner

    M1Gunner Full Access Member

    Posts:
    1,018
    Likes Received:
    1,105
    Joined:
    Feb 7, 2015
    Location:
    Gainesville, Fl
    Name:
    Jason
    All the resistor is doing is supplying different amounts of power to the motor. I’m actually very surprised with your findings considering it didn’t change with fan speed.
     
  9. warndogg

    warndogg Member

    Posts:
    45
    Likes Received:
    2
    Joined:
    Mar 14, 2015
    Name:
    justin
    So I finally put in a new blower motor and it has the exact same tick in it. I think I am going to try a different Heater resistor. Can you tell me exactly which one I need and a part number maybe? I have a 2006 yukon Denali.
     
  10. Doubeleive

    Doubeleive Elite Member Supporting Member

    Posts:
    2,744
    Likes Received:
    1,623
    Joined:
    Nov 7, 2017
    Location:
    Stockton, Ca.
    Name:
    Wes
    my ex wifes suburban does that, hers has the slider controls, I found that if I adjust the passenger side control just a pinch up from max it doesn't do it, so I told her just use it like that, no problem. lol I think it's a door actuator that just doesn't like to be at max
     

Share This Page