1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2008 Hybrid radio issue

Discussion in 'Hybrid General Discussion' started by Cara Washington, Jan 28, 2021.

  1. Cara Washington

    Cara Washington TYF Newbie

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jan 28, 2021
    Name:
    Cara
    Hello. I have an '08 Hybrid. The hybrid battery is only charging at about 40%, but I'll be replacing that very soon. My issue is-and I hope someone can steer me in the right direction-the radio cuts out, and goes back to the clock/time. Its been fine up until last August. The radio would come one when the button was pushed, play for second or two, then cut off. Intermittently-while driving-the radio would flash on then off again. I don't know what's causing this. I did notice that, when I pressed the outer plastic trim, the radio would come on, but also cut off again. I called a radio repair shop, who said the radio probably needs to be replaced, at around $1500! I'm thinking maybe there's a loose connection somewhere. At least that's what I'm hoping. Where or who should I take it to, to diagnose? A dealer? A radio shop? Help!
     
  2. wsteele

    wsteele Full Access Member

    Posts:
    281
    Likes Received:
    318
    Joined:
    Dec 26, 2020
    Name:
    Bill
    Hi Cara,

    Welcome to the forum.

    I have an ‘07 Yukon SLT. My radio has exhibited a similar symptom from time to time. My is not as persistent as yours sounds, only occasionally coming up with just time being displayed like it was turned off (it is always on normally) and not responding to being turned on. Every time mine has happened like that, it lasted the length of that current drive and has always come back on with the next trip. I have no idea what causes it and the dealer has never been able to find the fault (it never has been malfunctioning when near the dealer).

    It sounds like your first guess might turn out to be a good one (loose connection), but even if it needs replacing, I think $1500 sounds way too high. I think you can find a replacement for under $500 and install shouldn’t be all that much at a reputable shop.

    Good luck.
     
    Cara Washington likes this.
  3. petethepug

    petethepug Full Access Member

    Posts:
    878
    Likes Received:
    630
    Joined:
    May 4, 2016
    Location:
    SoCal
    Name:
    Michael
    I’ve seen NEW hybrid units on eBay for $5-$7h. Don’t have the part number to point you to it right now.


    Sent from my iPhone using Tapatalk Pro
     
    Cara Washington likes this.
  4. Jason in DLH

    Jason in DLH Cheeseburger and Fries

    Posts:
    1,107
    Likes Received:
    1,134
    Joined:
    Sep 4, 2020
    Location:
    MN
    Name:
    Jason
    If I remember correctly, this is what happened with my radio in my ‘07 as well. Gave me a reason to put in a better Kenwood receiver and some bumps. :) Now my music sounds way better (even without the subs).
     
    Cara Washington likes this.
  5. BG1988

    BG1988 Full Access Member

    Posts:
    1,988
    Likes Received:
    802
    Joined:
    Nov 14, 2018
    Name:
    Brent
    sounds like a bad soldering joint
     
    Cara Washington likes this.
  6. Cara Washington

    Cara Washington TYF Newbie

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jan 28, 2021
    Name:
    Cara
    Thank you!
     
  7. Cara Washington

    Cara Washington TYF Newbie

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jan 28, 2021
    Name:
    Cara
    I'll have that checked as well. Glad I'm not the only one!
     
  8. Cara Washington

    Cara Washington TYF Newbie

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jan 28, 2021
    Name:
    Cara
    I'm going to have that checked out. Thanks!
     

Share This Page