P0157 Only on hard acceleration

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

TheEnder53

Member
Joined
Jan 13, 2024
Posts
61
Reaction score
49
Hello everyone.

I’m going through repairing everything on my 01 Tahoe.

Right now, on hard acceleration at wide open throttle it sets a P0157. If i don’t drive it hard everything is ok and the code will never set.

02 sensor voltage according to HP tuners for B2S2 is quite low from what i remember seeing with engine off cold. Looking for a direction to go in with this. 02 sensor was replaced with one from Autozone. Didn’t fix it.
 

Fless

Staff member
Super Moderator
Joined
Apr 2, 2017
Posts
10,788
Reaction score
21,516
Location
Elev 5,280
Any exhaust leaks before or right after the cat? Something to cause it to run lean when you're at WOT?

What do the short- and long-term fuel trims look like?
 
OP
OP
TheEnder53

TheEnder53

Member
Joined
Jan 13, 2024
Posts
61
Reaction score
49
Any exhaust leaks before or right after the cat? Something to cause it to run lean when you're at WOT?

What do the short- and long-term fuel trims look like?
From what I can tell, absolutely no exhaust leaks from the exhaust manifold back to the B2S2 02 sensor. Even has all its exhaust manifold bolts still.

If I recall correctly, using HP tuners, short term fuel trims would jump all the way into the positive red (and i think long term would too, i need to look again) until I let off the gas.
 
OP
OP
TheEnder53

TheEnder53

Member
Joined
Jan 13, 2024
Posts
61
Reaction score
49
Apologies for delays too, been very busy with family stuff.
 

Forum statistics

Threads
130,014
Posts
1,824,841
Members
93,440
Latest member
Danali74
Top