No crank or start

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Swagfu

Full Access Member
Joined
Apr 19, 2022
Posts
186
Reaction score
201
Location
Deland, Fl
Go back and verify the plug wires are in the correct position. This happened to me and I had two wire switched around. Fixed them and the truck started right up.
 

exp500

Full Access Member
Joined
May 14, 2017
Posts
1,693
Reaction score
1,473
You definately need Frame to Body and Frame to engine grounds, Along with another 10 Ga to Radiator support from battery. Your no headlights should have lit the way for you.
 

rockola1971

Full Access Member
Joined
Dec 29, 2016
Posts
2,187
Reaction score
2,619
Location
Indiana (formerly IL)
First you gotta get those grounds corrected. Check starter relay terminal a7 in the schematics on first page here and see if ground is connected to the coil of starter relay. It will never crank without bypassing the relay if that ground is missing.
As far as your ignition problem that distributor has to be set dead close to "Zero" point and then adjusted with a scanner while engine is running(this is because the engine has electornic ignition advance). There is also a plug you have to disconnect during the procedure.
How do I know you ask.....I had a 1999 GMC Sierra Z71 Vin R and I sold it with almost 300K on the clock with original engine that has never been opened up and had 82k when i bought the truck.. Its still going today and I sold it over 2yrs ago. ;)
Recheck your firing order on the wires at the cap. Get it to TDC#1 and see where the rotor is pointing.
 

Forum statistics

Threads
124,116
Posts
1,727,234
Members
85,690
Latest member
Sleepy01
Top