2000 Yukon Denali running rough

Discussion in 'Engine & Drivetrain' started by Adiel, Jul 6, 2018.

  1. Adiel

    Adiel TYF Newbie

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jul 6, 2018
    Name:
    Jim
    Engine suddenly started skipping overnight with no apparent cause. Mechanic runs a scan to reveal timing out by 27 degrees. Checks distributor and finds nothing wrong, says must be timing chain. Now says nothing wrong with timing chain. He is lost, doesn't know what to do even after consulting with GM mechanic friends. HELP!! By the way, just relaying to you what he told me. Know the mechanic very well and has been great in the past.
     
  2. Doubeleive

    Doubeleive Elite Member Supporting Member

    Posts:
    2,528
    Likes Received:
    1,469
    Joined:
    Nov 7, 2017
    Location:
    Stockton, Ca.
    Name:
    Wes
    my first guess is the distributor must be bad, have you tried replacing it?
     
  3. Adiel

    Adiel TYF Newbie

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jul 6, 2018
    Name:
    Jim
    My mechanic is checking that possibility again. He is still working on it. Thanks
     
  4. Adiel

    Adiel TYF Newbie

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jul 6, 2018
    Name:
    Jim
    Could a bad computer module cause this?
     
  5. Adiel

    Adiel TYF Newbie

    Posts:
    4
    Likes Received:
    0
    Joined:
    Jul 6, 2018
    Name:
    Jim
    You're right, replaced the distributor and all is well!
     

Share This Page