1999 Tahoe (old style) power door lock problem

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

apd6847

TYF Newbie
Joined
Jul 1, 2010
Posts
4
Reaction score
0
Location
Central Louisiana
My power door locks are not working on my truck, when you press the lock or unlock you just hear a clicking coming from the relay under the dashboard that I have already pulled out. I have checked the big silver fuses in the interior fuse panel and they are fine, my power seats, windows and mirrors all still work, and I've tried new switches as well. Could ALL of my actuators be bad? or maybe the relay under the dash? Please Help!

Thanks
~Andrew
 

the big blue bus

Full Access Member
Joined
Apr 18, 2010
Posts
1,049
Reaction score
1
Location
richmond, va
im interested as well. got a 95 doors and driver seat dont work. seats not that big of a deal since it stoped where i can drive but locks can get annoying
 

grimm

Full Access Member
Joined
Mar 2, 2010
Posts
314
Reaction score
0
Location
Bay Area, CA
I'd check the relay. I doubt all of your actuators are bad. After you solve that problem, then you'll be able tell which actuators are bad, if any.
 

RSymons

Full Access Member
Joined
Feb 27, 2010
Posts
99
Reaction score
1
Location
Texas
maybe this will help?....A while back my door locks stopped working on my 97 Tahoe. It was a blown fuse, which was caused by the dashboard cigarette lighter. Every time i pushed it in, it would blow the fuse. So i stopped using the lighter and just replaced the fuse. haven't investigate why it is doing that yet!
 

vanilla_gorilla312

Full Access Member
Joined
Nov 24, 2009
Posts
62
Reaction score
0
I was actually going to post this same problem I've been having with my 97 hoe. Checked all the fuses and they are fine. From one day to the next, it quit working. I found the actual unit you are talking about that makes the "clicking" sound. It's a small plug/relay looking box that is located directly above the gas pedal. I opened it up and could see the inner workings and they seem to work? I'm going to try checking the few wires that run out of it to see if one is loose or frayed, if not I'm going to replace it and let you know if that was the problem. Any other ideas???
 

NvOffRoad

TYF Newbie
Joined
Sep 2, 2010
Posts
1
Reaction score
0
Hey guys new here. I had the same problem, i would hear the clicking, locks wouldnt move, switches had power. Today I was working on it, and found out i was missing the circuit breaker in the fuse box. There are 2 of them. the bottom is for power windows and the top one is for the power seats and power door locks. come to find out mine was missing the one for the door locks cause there was a short in my power seat. unplugged the seat, and put the circuit breaker back in and the locks work now. all but the barn door. need to replace the actuator tomorrow.

Hope this helps you guys.
 
OP
OP
A

apd6847

TYF Newbie
Joined
Jul 1, 2010
Posts
4
Reaction score
0
Location
Central Louisiana
Well i have a breaker in both of the slots and the locks still don't work, this is really getting on my nerves lol
 

oknik123

TYF Newbie
Joined
Oct 11, 2010
Posts
13
Reaction score
0
I'm having the same problem as well. When I press on the lock button the two back doors lock but the two front doors wont. I took off the driver door panel and looked at the actuator for the locks when I pressed it and it was kinda half ass working.... I pressed down on the rod that was connected to the actuator and it worked better but I can't just take off the panel every time I want to use the lock button. I can push down on the lock itself but it gets annoying when I have to manually lock everything up every time I want to lock it up.

Do you think it could be a wiring problem since it is both the front doors? what else could it be?
 

Ferg_osu1

TYF Newbie
Joined
May 9, 2011
Posts
1
Reaction score
0
Same thing....

Any luck with the door locks? I have the same truck except 4 door.
I'm having almost the same problem. Just curious. One day they all work and the next some don't. Now my back doors won't open.......sometimes.

Thanks,

Ed
 

Forum statistics

Threads
130,041
Posts
1,825,402
Members
93,475
Latest member
JustinCole

Latest posts

Top