No high speed cooling fans?

dpollak81

Member
Joined
Jul 25, 2022
Posts
46
Reaction score
51
Location
Lincoln, CA
Hey it’s been really hot here the last few weeks and noticed that the Denali A/C is struggling anytime we are stopped and won’t cool down when you first start it till you get moving.

Checking it out yesterday and I don’t think the high speed on the cooling fans is engaging. if I remember right if you start it after it’s been sitting in the sun in a 100 degree day, the fans sound like a jet engine if you have the A/C on.

The fans are spinning but quiet…. I know GM on many rigs did a right fan relay and left fan relay then a high speed relay but I can’t find a high speed relay anywhere.

Any ideas on where to start?
 
OP
OP
dpollak81

dpollak81

Member
Joined
Jul 25, 2022
Posts
46
Reaction score
51
Location
Lincoln, CA
Oh wow didn’t realize that. So what would trigger the high speed? It seems like the fans should be drawing more air while sitting.

It had the previous condenser replacement around 65k that was required on all these models.
 

Doubeleive

Wes
Supporting Member
Joined
Nov 7, 2017
Posts
18,921
Reaction score
25,132
Location
Stockton, Ca.
Oh wow didn’t realize that. So what would trigger the high speed? It seems like the fans should be drawing more air while sitting.

It had the previous condenser replacement around 65k that was required on all these models.
it depends on the coolant temp and the ac demand, I have seen a couple people have a coolant temperature sensor issue but I think in both cases the fans were running high speed pretty much all the time, you would have to google for the technical reasons the fans would be put in high speed mode and then try to replicate that and see if the fans respond properly. you could try cranking the ac up and do high speed run down the highway for a couple miles then pull over real quick and check to see if the fans have kicked up high? if it's not overheating then it's probably fine.
 
OP
OP
dpollak81

dpollak81

Member
Joined
Jul 25, 2022
Posts
46
Reaction score
51
Location
Lincoln, CA
I've read a ton about the fans staying on and the faulty temp sensor.

Maybe it needs a recharge or has a small leak then... I just can't find much information as to why the fans wouldn't kick on into high speed. they kick on and off with the A/C on and off if I test that with the engine being cooler.

I'll see if I can get the engine good and hot and see if it will kick onto high speed then. The hard thing is that even in HOT HOT temps the engine stays at 200-210.
 
Joined
Apr 11, 2018
Posts
5,038
Reaction score
8,616
Location
St. Louis
When I remote start mine on a 90-100* day the fans kick on and are loud, but they're not on high. After a couple minutes, usually about the time we're getting in, they do kick to high though.
 
OP
OP
dpollak81

dpollak81

Member
Joined
Jul 25, 2022
Posts
46
Reaction score
51
Location
Lincoln, CA
When I remote start mine on a 90-100* day the fans kick on and are loud, but they're not on high. After a couple minutes, usually about the time we're getting in, they do kick to high though.
Yeah ours don’t seem to sound like they are spinning to fast…. When we remote start now and let it sit for a couple of minutes the air is not blowing cold. It’s just barely cooler…
 

Tahoe14

Full Access Member
Joined
Jun 10, 2014
Posts
1,382
Reaction score
558
Location
Central Fl
Like you said possibly low on freon, could be the condensor issue that many have experienced and there is a TSB.
 
OP
OP
dpollak81

dpollak81

Member
Joined
Jul 25, 2022
Posts
46
Reaction score
51
Location
Lincoln, CA
Well got Mjolnir back from the shop and seems like all components were working fine but it had about half the refrigerant in the system it was supposed to. Supposed to have 2lbs and it only had .96 lbs… They leak tested it and no leaks so not sure what’s going on there so we’ll keep an eye on it.

Works great now that it I has the correct amount of refrigerants and the auto setting is much more chill now that it can keep up.
 

Forum statistics

Threads
122,016
Posts
1,691,030
Members
83,323
Latest member
wbanksjr
Top