Driver power seat stuck. Track misaligned.

Discussion in 'Interior' started by YukonSteve, Oct 2, 2018.

  1. YukonSteve

    YukonSteve TYF Newbie

    Posts:
    1
    Likes Received:
    0
    Joined:
    Oct 2, 2018
    Name:
    Steve
    Hi everyone, I have a 2002 Yukon and the Electric driver seat is stuck unable to go forward and back. I have swapped out the motor with the passenger seat and it worked on the passenger seat with the passenger seat motor unable to move the driver seat. On the problem seat the motor engages but just cannot move the seat. This is definitely not an electrical problem. I took off the seat cushion and was able to determine that the tracks were misaligned. When I engaged the seat the inside track is able to move a little bit but the outside track seems jammed. The next thing I did was to remove the motor and manually move the cables from the motor to the little transfer case at the track. As expected the cable for the inside track was able to move it but the outside track won't move at all. The last things I tried were to hit the track with a hammer while engaging the switch. I also stuck a screwdriver inside the track to hit the mechanisms in there. I noticed there is a little rust on that track and could possibly be the cause of it binding. I would like to be able to manually adjust the screw inside the track but can't figure out how to get to it or dismantle it. Anyone on here have some bright ideas? If I can't find a solution this way my next step would be to buy a new/used seat base and track. However, this presents a problem too as the 4 seat mounting bolts are covered by the track. I can access two bolts but cannot access the rear ones because the seat track is over it. I can see on the passenger seat that when you bring the seat all the way forward it reveals the mounting bolts. Is there an easier way to get the seat off without doing some major demolition? Thanks for all your thoughts in advance.
    Yukon Steve
     

Share This Page