Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

guywith2015LT

TYF Newbie
Joined
Nov 6, 2022
Posts
24
Reaction score
6
Howdy ppl, just found out about this forum and wanted to introduce myself. I recently bought a 2015 Tahoe PPV LT 1500 for a good deal. It has about 82k on it, 4x4 and have some good features.

Being a PPV it has some flaws like no sound (chime, radio, horn) and the 12v outlet, household outlet not working. I am not sure if this is the right place but would love to get some help to get this thing working like a normal car. It also had a dead battery and I replaced it but the earlier problem still persist.

I have checked the fuse for horn located under the hood and it seemed fine, on the driver side there is another fuse panel and it don't really have any fuse relating to the issues I have (I just read the labels and decided on this). If anyone have any experience or can help me out I would really appreciate it.

Hope to hear from you guys.

Thanks for reading
 
OP
OP
G

guywith2015LT

TYF Newbie
Joined
Nov 6, 2022
Posts
24
Reaction score
6
forgot to mention, the rear door panels were removed, window switch and the speakers as well. I connected the rear window switches and they don't roll but I can control them from driver seat. If someone knows how to tackle my issues I would really appreciate it. I'll post some pictures after taking it to a car wash.
 

Chickensandwich

Full Access Member
Joined
Nov 29, 2019
Posts
255
Reaction score
110
Howdy ppl, just found out about this forum and wanted to introduce myself. I recently bought a 2015 Tahoe PPV LT 1500 for a good deal. It has about 82k on it, 4x4 and have some good features.

Being a PPV it has some flaws like no sound (chime, radio, horn) and the 12v outlet, household outlet not working. I am not sure if this is the right place but would love to get some help to get this thing working like a normal car. It also had a dead battery and I replaced it but the earlier problem still persist.

I have checked the fuse for horn located under the hood and it seemed fine, on the driver side there is another fuse panel and it don't really have any fuse relating to the issues I have (I just read the labels and decided on this). If anyone have any experience or can help me out I would really appreciate it.

Hope to hear from you guys.

Thanks for reading
No radio? I’ve heard of horns being disconnected, and the chime…well, i would love to get rid the chime. The rear doors likely had flat panels over them. It might get a little pricey getting everything back together, but it’s the journey, not the price, right?
 
OP
OP
G

guywith2015LT

TYF Newbie
Joined
Nov 6, 2022
Posts
24
Reaction score
6
No radio? I’ve heard of horns being disconnected, and the chime…well, i would love to get rid the chime. The rear doors likely had flat panels over them. It might get a little pricey getting everything back together, but it’s the journey, not the price, right?
So they just cut off horns? any clue as to where to start to fix this issue (maybe I can fix it myself if its just connecting wires back)? I live in Chicago and use horn at least once a day.

I don't really care about the chime (kinda miss it because of my other car habit) but the important issue is radio. Its completely mute and I hate driving by myself or the fam with no music playing. The auto drl, no audio, DC 12V and regular outlet don't work so I thought this must be a small issue and they must be connected but seems not.

I have most of the parts, the seller included everything since it was from a PD. I really want to get the back doors to work from inside and get the electrical figured out.

I thought there would be bunch of forums/YT videos about PPV issues and I could fix it myself but didn't find much help expect here.
 

Chickensandwich

Full Access Member
Joined
Nov 29, 2019
Posts
255
Reaction score
110
With my last car, I just added an air horn. I didn’t want to tear in to the dash to find where they cut it
 

Hoeston

TYF Newbie
Joined
May 10, 2022
Posts
11
Reaction score
9
Drl likely was deleted from factory.
Check the 12v accessory outlet fuse. While you're at it check them all(both fuse panel boxes)with a tester. I had read what seemed like a good explanation of finding the horn wire somewhere. Pretty sure it was this forum if you search around you may find a guide.
 
OP
OP
G

guywith2015LT

TYF Newbie
Joined
Nov 6, 2022
Posts
24
Reaction score
6
thanks for the replies.
Drl likely was deleted from factory.
Check the 12v accessory outlet fuse. While you're at it check them all(both fuse panel boxes)with a tester. I had read what seemed like a good explanation of finding the horn wire somewhere. Pretty sure it was this forum if you search around you may find a guide.
With my last car, I just added an air horn. I didn’t want to tear in to the dash to find where they cut it

So I checked the fuse box on the passenger side and played around with the fuse pulling out and pushing back in and the speakers started to work. All I am left with no is the horn and window control from rear seats.

Air horn seems a good option but I would still have to find the wire from the original horn and connect to it tho? Wouldn't I be better off just fixing the original horn?

The only problems I have so far is outlets not working, horn and rear passenger window control from rear doors. Everything works besides that.

I am tryna get this big bertha to be used as a family car and it's coming along nice. Recently, removed the spotlights and fixed the holes in the a pillar with some black silicone (I don't want to spend tons of money at the body shop for now and silicone seemed the best option for time being use). Will upload some pics after a clean wash soon.
 

2015TahoePPV

Member
Joined
Apr 22, 2023
Posts
46
Reaction score
27
The rear windows need to be programmed (BCM) to work. You need to go to the dealer, they call the software people somewhere, they burn a program for your BCM that turns the windows on in the back, the dealer installs the software and they will work. (so I was told, I haven't done it yet, but its like $150).

The horn is a fun one that I fixed. There's a circuit in the upfitter harness that loops back on itself that completes the horn circuit. Its designed so the cops can toggle a switch and have the "regular" horn or the "I'm serious get out of the way" horn or siren. When they decomission the trucks, they sometimes just leave the wires cut.
 
OP
OP
G

guywith2015LT

TYF Newbie
Joined
Nov 6, 2022
Posts
24
Reaction score
6
The rear windows need to be programmed (BCM) to work. You need to go to the dealer, they call the software people somewhere, they burn a program for your BCM that turns the windows on in the back, the dealer installs the software and they will work. (so I was told, I haven't done it yet, but its like $150).

The horn is a fun one that I fixed. There's a circuit in the upfitter harness that loops back on itself that completes the horn circuit. Its designed so the cops can toggle a switch and have the "regular" horn or the "I'm serious get out of the way" horn or siren. When they decomission the trucks, they sometimes just leave the wires cut.
I still haven’t figured out the horn. These are all my wires that I found. The thick red wires from diver and passenger side. There is no connection to them in between. I am scared to drive around with no horn, would appreciate some help on how you got it to work.
 

Attachments

  • IMG_3131.jpeg
    IMG_3131.jpeg
    240.7 KB · Views: 14
  • IMG_3130.jpeg
    IMG_3130.jpeg
    200.6 KB · Views: 16
  • IMG_3133.jpeg
    IMG_3133.jpeg
    241.7 KB · Views: 15
  • IMG_3132.jpeg
    IMG_3132.jpeg
    240.8 KB · Views: 16
  • IMG_3134.jpeg
    IMG_3134.jpeg
    145.6 KB · Views: 14

Forum statistics

Threads
129,541
Posts
1,817,398
Members
92,752
Latest member
MrRuiz
Top