Weird Temperature Control On Defog

Discussion in 'Tech Info' started by lkrasner, Oct 9, 2019.

Car Parts
  1. lkrasner

    lkrasner Full Access Member

    Posts:
    109
    Likes Received:
    14
    Joined:
    Mar 2, 2014
    Name:
    Luke
    My heat/ ac controls work normal in every position except defog(windshield blower) when the control is rotated all the way that direction, the temperature control does not function properly. I get about 2 "clicks" of warm, then it blows full cold, no intermediate control as there should be and is on every other setting. Any Ideas? Probably unrelated, since I think this issue started sooner, but I also have no A/C in the rear, and the rear fan cuts in and out sporadically (really don't care about this one, I don't use the rear climate controls that much).
     
  2. UmmScott

    UmmScott Member

    Posts:
    66
    Likes Received:
    50
    Joined:
    Sep 1, 2019
    Location:
    Omaha
    Name:
    Scott
    First off... what system do you have? Do you have manual temp controls or do you have controls with automatic settings?

    It really helps here to have a scan tool like the tech2 that can communicate with the HVAC module and see what the blend doors are doing.

    If you have the automatic climate system, it will attempt to set the cabin temp of the car to exactly what you set it at. Example, you have the knob or number set at 75F. The air will come out hot but then as the cabin warms up it will modulate the blend door to maintain that. Alot of people dont like that or arent used to it but its the way it is designed. This system is highly dependent on that cabin temp sensor that is right above your head in the drivers seat in the headliner. If that sensor is failing, the system wont work right.

    Here's a quick test to confirm if its a sensor issue. (Assuming you have the computer auto climate system) set it to either the hottest setting or the coldest setting. If at that time you get full nice heat or AC then its most likely a sensor or something causing the issue. Full heat or full cold is the ONLY truly manual mode on these systems. Like i said, any other setting than those 2 and the system will modulate to get that setpoint in the car.

    Sent from my SM-G975U using Tapatalk
     
  3. lkrasner

    lkrasner Full Access Member

    Posts:
    109
    Likes Received:
    14
    Joined:
    Mar 2, 2014
    Name:
    Luke
    It is full manual controls. 3 vacuum (I assume?) operated knobs. Temperature control usually just changes the temperature of the air. I have a generic scan tool, but definitely not something that can access any climate control stuff.
     
  4. UmmScott

    UmmScott Member

    Posts:
    66
    Likes Received:
    50
    Joined:
    Sep 1, 2019
    Location:
    Omaha
    Name:
    Scott
    With a manual system u dont really need a high tech scan tool.

    Im not sure if its vacuum or electronic. We will need to find this info out

    Sent from my SM-G975U using Tapatalk
     
  5. Rocket Man

    Rocket Man Build It Better Supporting Member

    Posts:
    11,978
    Likes Received:
    16,385
    Joined:
    Dec 25, 2014
    Location:
    Oregon
    Name:
    Mark
    There is a reset procedure for the system that you can try. Either pull the positive battery terminal, wait awhile and then touch the positive cable to the neg post before reconnecting it or sometimes it resets by pulling all fuses labeled for the hvac system for 30 minutes. Don’t touch any controls after you start the engine afterwards for about 5 minutes while it recalibrated the actuators. There’s more info out there if you do a search, I’m just going by memory which seems to be failing more as I get older. Not guaranteed to fix your problem but sometimes it does fix it when something gets confused.
     
    UmmScott likes this.

Share This Page