Curt Spectrum Brake Controller - single click sound when braking (no trailer attached)

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

navyseal334

Full Access Member
Joined
Jan 19, 2022
Posts
132
Reaction score
78
Just had Curt Spectrum Brake Controller (51170) installed by the dealer on 23 suburban this is the dealer-endorsed aftermarket controller (sold on GM's accessory site).

I'm getting a loud click noise when I depress the brake (no trailer attached). Subsequently pressing the brake soon after the click doesn't cause another click sound. Click comes back after not braking for a minute.

My hunch is it's sending a signal but I've not had a brake controller before this vehicle so I'm not totally sure. Google doesn't turn up much for a clicking sound but the one result I can find for another controller indicates the click isn't normal...

Has anyone with this controller encountered this or know what it's doing?
 
OP
OP
navyseal334

navyseal334

Full Access Member
Joined
Jan 19, 2022
Posts
132
Reaction score
78
Bumping this to see if anyone has any idea before I take it back to the dealership. Click comes from under the dash. I'm confident it's sending a signal but my assumptino would be that it should detect when no trailer is attached and not do this.

It's not the end of the world but annoying enough that I want it gone.
 

StephenPT

Full Access Member
Joined
Jan 16, 2022
Posts
961
Reaction score
869
Location
St. Helens, OR
There's a module (box) that your dash mounted brake controller is connected to. Look under the dash and follow the wiring from the brake controller dial until you find the box. Disconnect that wiring harness and see if the sound goes away. It's likely the Curt controller box that is clicking because it sounds like you didn't hear this click before it was installed. If you take it to the dealer, they're going to blame Curt and tell you to contact them.

The only other thing I can think of trying is turning down the output to zero when you're not pulling a trailer. Maybe then it won't send a signal to that box and then you won't activate the relay that's clicking.
 

Forum statistics

Threads
128,282
Posts
1,796,897
Members
91,030
Latest member
Arkangel2487

Latest posts

Top