Brake Lights not working

Discussion in 'Tech Info' started by Doug Phillips, Oct 16, 2019.

Car Parts
  1. Doug Phillips

    Doug Phillips TYF Newbie

    Posts:
    1
    Likes Received:
    0
    Joined:
    Oct 16, 2019
    Name:
    Doug
    Hello guys , i'm sure this has been asked before on my '00 Tahoe the brake lights doesn't work even after replacing the the brake light switch . The third brake light doesn't work either, I've checked all fuses all of them are good . Any advise on this would be greatly appreciated. Thanks
     
  2. ivin74

    ivin74 05 Yukon Denali

    Posts:
    867
    Likes Received:
    381
    Joined:
    Aug 3, 2014
    Location:
    Pearland, Texas
    Name:
    Ivan
    I have a feeling it maybe the connection panel on the right rear quarter panel, the wires from the right tail light will lead you to the panel i'm talking about. Keep us posted
     
    rockola1971 likes this.
  3. rockola1971

    rockola1971 Full Access Member

    Posts:
    886
    Likes Received:
    364
    Joined:
    Dec 29, 2016
    Location:
    Indiana (formerly IL)
    Name:
    Mike
    I had a right brake light out on my Denali when I bought it. Traced it to the power wire for the right brake light right at the panel on passenger side underneath near axle. The wire was broke off about an inch from its plug in at that panel. The panel has no guard on it and isnt protected from anything. All it takes is drive over some brush or a rock to get kicked up going down the highway and strike that panel and wires can be broken easily.
     
    ivin74 likes this.
  4. PNW VietVet

    PNW VietVet Full Access Member

    Age:
    66
    Posts:
    2,468
    Likes Received:
    810
    Joined:
    Oct 8, 2014
    Location:
    Oregon
    Name:
    Ron
    Has anyone ever come up with a custom cover for that panel? Maybe something to keep water out too instead of just keeping brush from rubbing there.
     
    ivin74 and Big Mama like this.

Share This Page