A/C Ice Cold or Hot..no In-between

Discussion in 'Interior' started by SnowBuck, Aug 13, 2019.

  1. SnowBuck

    SnowBuck Full Access Member

    Posts:
    164
    Likes Received:
    10
    Joined:
    Nov 10, 2012
    Name:
    Rich
    Had the ol' hot on the left/cold on the right. Replaced the difficult behind-the-dash actuator = fixed. Now...dial in 60 or 88 = the same output at the vents!?!?!?!? When I dial up to the 90 degree setting it trips over. Nothing in-between?!?!?
     
  2. Merc1973

    Merc1973 Full Access Member

    Posts:
    242
    Likes Received:
    104
    Joined:
    Sep 16, 2016
    Location:
    Maryland
    Name:
    Merc1973
    A bad ambient temp sensor in the roof liner may cause that. You have the auto HVAC controls, right?
     
    swathdiver likes this.
  3. SnowBuck

    SnowBuck Full Access Member

    Posts:
    164
    Likes Received:
    10
    Joined:
    Nov 10, 2012
    Name:
    Rich
    Yes. Looked at RockAuto...saw a bunch of different looking ones. Exactly WHERE is it so I can pull it out and match up the pics?
     
  4. swathdiver

    swathdiver Full Access Member

    Posts:
    8,092
    Likes Received:
    6,563
    Joined:
    May 18, 2017
    Location:
    Treasure Coast, Florida
    Name:
    James
    There are 4 actuators for the front AC and 2 in the back. The left one is on the bottom behind the console or middle area. The right side is on top in the middle. The recirc is on top but towards the right and the "blend" is under the driver's foot well.

    The ambient sensors in the 900s look like little speaker grills in the headliner, 1-3 depending on trim level and options.
     
  5. SnowBuck

    SnowBuck Full Access Member

    Posts:
    164
    Likes Received:
    10
    Joined:
    Nov 10, 2012
    Name:
    Rich
    6 total actuators, 3 ambient sensors...forgetaboutit. Will just take it to the Dealer and say the magic words: "Fix It...I'll pick it up in the morning!". THAT's always worked before! LOL
     

Share This Page