No Brake Lights

Discussion in 'General Discussion' started by lkrasner, Apr 16, 2018.

  1. lkrasner

    lkrasner Member

    Posts:
    83
    Likes Received:
    2
    Joined:
    Mar 2, 2014
    Name:
    Luke
    After doing an oil change, fixing a window regulator, and a few other little things that had been bothering me, I was happily out on a drive the other day noting how damn near everything was working perfectly for once. This was until another driver pulled up and said "you know you ain't got no brake lights, right??" No, no I was not aware of this...

    Indeed, no brake lights are working, side or center. Running lights are on, but do not get brighter with brakes. Interestingly, cruise control still works too. Fuses and bulbs all check out good. I saw mention of a junction box near the rear right of the vehicle that is often at fault, but I didn't see anything there... Granted, it was dark and I was pissed off and didn't spend much time looking.

    '02 Tahoe 4x4 5.3 Flex. ~330,000 miles
     
  2. M1Gunner

    M1Gunner Full Access Member

    Posts:
    884
    Likes Received:
    938
    Joined:
    Feb 7, 2015
    Location:
    Gainesville, Fl
    Name:
    Jason
    The CHMSL and brake lights are on seperate circuits (but both fed by the stop lps fuse). Chmsl fuse and vehicle stop fuse both under hood. Since your tail lamps work we know the ground is good. If those two fuses look good the n check the “stop lps” fuse. If all three fuses are in fact good, I would then check the operation of the brake switch. Bc there are numerous contacts in the brake switch which also would result in no cruise BUT not always.
     
  3. M1Gunner

    M1Gunner Full Access Member

    Posts:
    884
    Likes Received:
    938
    Joined:
    Feb 7, 2015
    Location:
    Gainesville, Fl
    Name:
    Jason
    Here’s the schematic as well

    C8E4425E-9714-470F-B730-2E2CA40F215A.png
     

Share This Page