Recent content by CTUBS8732

  1. CTUBS8732

    No high speed cooling fans?

    Changed temp sensor now only one fan spins in low mode and the other kinda spins. Prior to replacing, both wouldnapin in low mode. Only rear ac blowing how it should. Refrigerant is good. I'm stuck in a rut with this one
  2. CTUBS8732

    No high speed cooling fans?

    When driving it’s cold
  3. CTUBS8732

    No high speed cooling fans?

    Mines is 2005 Tahoe. Usually the fans are on high as soon as I start the truck with the AC on. Now high mode never kicks in even if the truck is idling for an hour. It ain’t overheating but also ain’t no cold air coming out the vents, just cooler than outside air. Refrigerant level is good.
  4. CTUBS8732

    No high speed cooling fans?

    I’m having this exact same issue. I just replaced the whole cooling fan relay fuse block with a fresh one cause the original had burnt prong ports. Thought I had solved the issue when I found out the ground was mounted in a bad spot due to shotty repair by body guy so I regrounded to a better...
  5. CTUBS8732

    No high speed cooling fans?

    Did that fix your issue with your fans?
  6. CTUBS8732

    Oil pan gasket replaced, still leaking... Might be rear main seal?

    I got quoted $500 for rear main and 250 for oil pan gasket. The guy at the shop raised the price on me. Ended up paying $1200
  7. CTUBS8732

    When your new shop puts on the wrong tailshaft seal

    What kind of grease do you put on the seal?
  8. CTUBS8732

    When your new shop puts on the wrong tailshaft seal

    Thanks for verifying!!! Ordering as I type lol
  9. CTUBS8732

    When your new shop puts on the wrong tailshaft seal

    Is your 05 4x4 or 4x2?
  10. CTUBS8732

    Replaced driveshaft u joints, now leaking output seal

    Is your truck 4WD? I’m looking for the same seal but in the reviews all I see is this is for 2wd. On the gm parts online it has 3 different seals to pick from but none say 4WD only 2wd. Just don’t wanna grab the wrong part when removing/installing . I only have 1 vehicle lol.
  11. CTUBS8732

    Please help!!

    Have you checked you under the hood fuse box for burnt ports? I replaced whole cooling fan relay fuse box cause I had a similar issue. Problem solved for me.
  12. CTUBS8732

    what are these connectors to?

    Cleaned it up and ran the part # that's exactly what it is. I'm trying to figure what the white one is.
  13. CTUBS8732

    1999 Tahoe/Lifter or Exhaust Manifold?

    I did this and had a few loose ones and 2 broken ones. Replaced the ones I could and used a repair clamp on the broken ones.
  14. CTUBS8732

    what are these connectors to?

    The black or white one?
  15. CTUBS8732

    P1133 code keeps throwing All new denso o2 sensors

    Bro they sell a clamp to fix the broken manifold bolt issue. I used one on the front driver's side bolt and last firewall bolt. Firewall bolt was PITA but the front one went on on 10 mins.
Top