Thin gray line tahoe build

OP
OP
T

thingraylinetah

Full Access Member
Joined
Sep 20, 2021
Posts
215
Reaction score
233
Location
Crossville Tennessee
Okay so I went to install a new digital climate control in my tahoe. The main bluev plug plugs into the socket on the module labeled "blue" the other port is listed as "gray" my other wire is black and won't plug into the port labeled gray. How do I fix this?
 

Tonyrodz

Resident Resident
Joined
Feb 16, 2012
Posts
28,720
Reaction score
38,814
Location
Central Jersey
Okay so I went to install a new digital climate control in my tahoe. The main bluev plug plugs into the socket on the module labeled "blue" the other port is listed as "gray" my other wire is black and won't plug into the port labeled gray. How do I fix this?
You sure you have the correct head unit?
 

Tonyrodz

Resident Resident
Joined
Feb 16, 2012
Posts
28,720
Reaction score
38,814
Location
Central Jersey
That's weird. Are the part numbers the same? How many prongs in the unit compared to the plug?
 

Rocket Man

Mark
Supporting Member
Joined
Dec 25, 2014
Posts
23,668
Reaction score
43,378
Location
Oregon
Okay so I went to install a new digital climate control in my tahoe. The main bluev plug plugs into the socket on the module labeled "blue" the other port is listed as "gray" my other wire is black and won't plug into the port labeled gray. How do I fix this?
Buy the correct control. Get the PN off the back of yours and look for the same part. Never trust EBay’s compatibility charts. There’s too many different RPO options on these trucks.
 

Forum statistics

Threads
119,449
Posts
1,646,570
Members
80,585
Latest member
ydinger
Top