Slight "thud" on moderate accel from standstill

Discussion in 'Engine & Drivetrain' started by Bucky1, Jul 17, 2019.

  1. 14RamHemiSport

    14RamHemiSport Member

    Posts:
    72
    Likes Received:
    35
    Joined:
    May 21, 2019
    Name:
    Justin
    That's why I asked year make and model. My wife has an 09 Denali awd. We get a light thud once in a while when going from on the gas, letting off (say to turn) then getting back on it is when we get the thud. It's not every time though. Seems to be a concensus of drivetrain play in these trucks.
     
  2. wjburken

    wjburken Supporting Member

    Posts:
    2,438
    Likes Received:
    3,813
    Joined:
    Dec 26, 2017
    Location:
    Eastern Iowa
    Name:
    Wade
    When I experienced this with my 2007 Denali, the first time at 180K, it was a broken motor mount which was replaced. The second time I experienced the "thud", at 270K, it ended up being a combination of slack in the AWD transfer case and worn out front differential. Swapped them both out and thud went away. I think the slack in the transfer case accelerated the wear in the front differential.
     
    Rocket Man likes this.
  3. Rocket Man

    Rocket Man Build It Better Supporting Member

    Posts:
    12,691
    Likes Received:
    18,593
    Joined:
    Dec 25, 2014
    Location:
    Oregon
    Name:
    Mark
    It’s not normal. A thud means slack or play somewhere that will only get worse over time. You should never have to be careful when hitting the gas. It’s probably time to do some diagnosing if you hear or feel a thud. Could be motor mount, differential, transfer case, transmission, u-joint etc. but whatever it is will probably cause wear on other components over time.
     
    wjburken likes this.
  4. 14RamHemiSport

    14RamHemiSport Member

    Posts:
    72
    Likes Received:
    35
    Joined:
    May 21, 2019
    Name:
    Justin
    I will be sure to look into it further. Sounds like we have it narrowed down to a few things at least.
     
    Rocket Man likes this.
  5. Koop

    Koop TYF Newbie

    Posts:
    5
    Likes Received:
    8
    Joined:
    Aug 1, 2014
    Name:
    Anthony
    Don't know if people are still answering but here was my issue:

    2007 Yukon Denali XL AWD

    Thud noise when accelerating from stop or thud in decrease of speed in the lower range


    Once on a lift my uncle and I found that the issue was these mounts (differential):




    You can also inspect the engine mounts and tranny mounts but the differential mounts were basically done and gave so much play (damn near a good inch and some change). Now I won't play when I say this was a full day project even with a mechanic whose done this for 35+ years. Once the mounts were replaced...not a single piece of noise. Shifting into drive or reverse, nothing. Accelerating, nothing... decreasing speed, nothing. Check those mounts on top of other suggestions others have given but as taught to me by a old schooler, start with your mounts and work inward. Definitely would like to hear an update on results.
     
    donjetman likes this.

Share This Page