Shifts hard into drive and reverse.

Discussion in 'Engine & Drivetrain' started by Chris Mckowen, Nov 7, 2018.

  1. Chris Mckowen

    Chris Mckowen TYF Newbie

    Posts:
    5
    Likes Received:
    5
    Joined:
    Sep 26, 2018
    Name:
    Chris
    2004 Yukon with 186K. When I put into drive and reverse, it goes in hard, makes a clunck sound, but not like a u joint, more like just too much pressure. Also sometimes does this when I get on and off the gas while driving. Any ideas?
     
  2. SnowDrifter

    SnowDrifter Full Access Member

    Posts:
    634
    Likes Received:
    263
    Joined:
    Sep 5, 2016
    Location:
    Wa
    Name:
    Chris
    Hard shifting?

    How's your fluid look?
    How do the accumulators look?
    What's your line pressure?


    Clunk?
    Check basically every mount and u joints. Dont assume they're good cause if they're not, you'll spend a lot of time repairing around the issue
     
  3. Galante

    Galante Elite Member Supporting Member

    Posts:
    9,940
    Likes Received:
    8,137
    Joined:
    Nov 6, 2016
    Location:
    Up here
    Name:
    Pete
    Wut he said, plus motor mounts... not sure if that was included in ‘all mounts..’
     
  4. CountryBoy19

    CountryBoy19 Full Access Member

    Posts:
    155
    Likes Received:
    81
    Joined:
    Jun 8, 2018
    Location:
    Southern Indiana
    Name:
    Mark
    And if your U-joints are good, pull the caps off the rear joint and rotate your differential yoke... Do it rotate more than 1/8"? If so, you have worn spider gears etc in your diff. I just replaced mine and my clunk is finally gone!!!!
     

Share This Page