Rear view mirror question

Discussion in 'Audio & Electronics' started by 707Tahoe, May 18, 2013.

  1. Doubeleive

    Doubeleive Elite Member Supporting Member

    Posts:
    2,753
    Likes Received:
    1,627
    Joined:
    Nov 7, 2017
    Location:
    Stockton, Ca.
    Name:
    Wes
    junk yard gives a warranty too at least all the ones I have been to do, usually 30 days
     
  2. Justinj360

    Justinj360 Senior Member Supporting Member

    Posts:
    338
    Likes Received:
    27
    Joined:
    Jan 2, 2014
    Name:
    Justin
    This is what I'm working with:

    WP_20171203_17_50_44_Pro_LI.jpg
     
  3. Justinj360

    Justinj360 Senior Member Supporting Member

    Posts:
    338
    Likes Received:
    27
    Joined:
    Jan 2, 2014
    Name:
    Justin
    I think I just found part of the issue. R74 (Bottom in picture) is completely missing a component. That probably explains why the buttons don't light up. Is it possible to use something else to connect it? Like a resistor? No idea what was there originally.
     
  4. Tahoe69Va

    Tahoe69Va TYF Newbie

    Posts:
    2
    Likes Received:
    0
    Joined:
    Dec 15, 2017
    Name:
    William
    Will take out mirror Saturday and try to resolder all 6 . Did my daughter cluster and all worked great
     
  5. ticketmagnet

    ticketmagnet TYF Newbie

    Posts:
    10
    Likes Received:
    0
    Joined:
    Jan 2, 2013
    Location:
    Grand Rapids, MI
    Name:
    Luke
    Just because a component isn't populated doesn't mean it's missing. It's common to design features into a board that aren't implemented, based on which parts are installed. For example, you may not know whether you want a signal pulled high or low, so you do both. Then the parts list will be missing one of the parts (you would never want both populated at the same time). Look to see if the pads look "new" or if something was soldered there and fell off.
     
  6. Justinj360

    Justinj360 Senior Member Supporting Member

    Posts:
    338
    Likes Received:
    27
    Joined:
    Jan 2, 2014
    Name:
    Justin
    Okay new plan. I can't get this mirror to work (Although, recently everything on it did work one morning, including OnStar) so does anyone know if a mirror from a newer vehicle will work with my 2004? I'm looking at part number 15139492 for an 07-08 I believe. I know the rain sensor (I'm assuming that's what that is anyway) wouldn't work with mine but the plugs look very similar.
     
  7. HiHoeSilver

    HiHoeSilver Away! Supporting Member

    Posts:
    5,371
    Likes Received:
    5,536
    Joined:
    Feb 28, 2017
    Location:
    Chicago
    Name:
    Nate
    If you're thinking replace it, you may as well try to reflow it first. Your can do it in your oven, or with a heat gun ...
     
    treehan77 likes this.
  8. Justinj360

    Justinj360 Senior Member Supporting Member

    Posts:
    338
    Likes Received:
    27
    Joined:
    Jan 2, 2014
    Name:
    Justin
    I have, this thing has more problems than just the common ones.
     
  9. bob67cam

    bob67cam TYF Newbie

    Posts:
    1
    Likes Received:
    1
    Joined:
    Jul 17, 2018
    Name:
    bob
    so i did the reflowing of the input wires and the resistors, plugged in the mirror and it worked great... for a couple days, now it works once in a great while, the rest of the time most of the lcd is just lit up, any ideas for that? is there something i missed or just a bad mirror?
    heres a horrible picture my wife took, granted it sure felt like 178 degrees that day, i promise, it wasnt...

    20180715_202405.jpg
     
    Merc1973 likes this.

Share This Page