Really need help.... 2001 s10

Discussion in 'Other Vehicles' started by Nickct203, Jan 7, 2019.

  1. Nickct203

    Nickct203 TYF Newbie

    Posts:
    7
    Likes Received:
    0
    Joined:
    Feb 2, 2018
    Name:
    Nick
    I'm working on my brother in law's 01 s10 5 speed. His slave cylinder went bad so I had to pull the tranny to replace it. I have the tranny back up to get bolted back to the engine but I can not get the main shaft to spline into the engine. The Bell housing is lined up with the block, I have 2 bolts in it 1 on each corner on the bottom, but can not get it to go in. I didn't touch the clutch or anything other than the slave cylinder. Wtf can I do? It's hard enough since I just had half my left pointer finger amputated November 1st, I need some kind of advice to help me here. Please someone help.
     
  2. Galante

    Galante Elite Member Supporting Member

    Posts:
    10,186
    Likes Received:
    8,414
    Joined:
    Nov 6, 2016
    Location:
    Up here
    Name:
    Pete
    Do you have a clutch alignment tool? They’re cheap, id pick one or a set up and make sure that slides in and go from there.
     
    Big Mama and Dcmaynor like this.
  3. Big Mama

    Big Mama Full Access Member

    Posts:
    599
    Likes Received:
    200
    Joined:
    Jul 21, 2015
    Location:
    Virginia
    Name:
    Steven
    Agreed things move around when separated and it may have been that the pilot bearing got nicked. Try the alignment tool. Any reason not doing clutch while tranny is out? Much cheaper now.
     
    kbuskill and Galante like this.

Share This Page