1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Randeez 2012 Yukon Denali

Discussion in 'Under Construction' started by randeez, Sep 29, 2017.

  1. Dantheman1540

    Dantheman1540 Full Access Member

    Posts:
    1,874
    Likes Received:
    3,578
    Joined:
    Feb 13, 2020
    Location:
    Sugar Loaf Mountain
    Name:
    Dan
    I like the idea of a big inline pump, after having a Walbro die in my RCSB and being paranoid about the gates submersible deteriorating I think my next setup will be inline or a surge tank.
     
    Sam Harris likes this.
  2. randeez

    randeez Full Access Member

    Posts:
    1,964
    Likes Received:
    4,588
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    not having to listen to it all the time, if one or the other dies im not stranded, was hoping to retain remote start and stuff but have a different issue going on that wont allow it to work - when i key off it shows my mph in the scanner as 164mph or something like that has to do with it, 4l80 swap problems just havent looked into it.
    would be nice to have some safety in place incase the big pump dies mid pull but would need to add additional controllers.
     
    Sam Harris likes this.
  3. Dantheman1540

    Dantheman1540 Full Access Member

    Posts:
    1,874
    Likes Received:
    3,578
    Joined:
    Feb 13, 2020
    Location:
    Sugar Loaf Mountain
    Name:
    Dan

    A fuel pressure shut off safety would be nice. I had the hotwire kit connector get loose and it shutoff white tuning on a WOT full boost pull. I crapped my pants but luckily it was okay. A triple pump surge tank fed by a factory pump would be nice. I doubt 3 pumps would die at once but you never know.
     
    Sam Harris likes this.
  4. iamdub

    iamdub Full Access Member

    Posts:
    11,658
    Likes Received:
    17,741
    Joined:
    Apr 23, 2016
    Location:
    Li'l Weezyana
    Name:
    Chris
    Yo, dawg, I herd you like fuel pumps...


    [​IMG]
     
  5. randeez

    randeez Full Access Member

    Posts:
    1,964
    Likes Received:
    4,588
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    Doubeleive, pwtr02ss, mikeyss and 2 others like this.
  6. gat0r

    gat0r Full Access Member

    Posts:
    1,897
    Likes Received:
    1,399
    Joined:
    Dec 11, 2015
    Location:
    DFW
    Name:
    Jay
    i like Evans coolant.
    had it in few prior vehicles.
     
    randeez and Sam Harris like this.
  7. randeez

    randeez Full Access Member

    Posts:
    1,964
    Likes Received:
    4,588
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy

    Thats what I keep hearing, figured i would try a different approach.
     
    Rocket Man and Sam Harris like this.
  8. randeez

    randeez Full Access Member

    Posts:
    1,964
    Likes Received:
    4,588
    Joined:
    Sep 29, 2017
    Location:
    south florida
    Name:
    randy
    well gents... i think i've got the cooling system whooped

    soo i ordered that evans coolant, a new expansion tank, some crap to mess with the steam ports. only the coolant came in so far but i figured before i dumped the expensive coolant in and still had problems, maybe i should just try some cheap 50/50 mix stuff to see if a higher boiling point would help.

    grabbed 2 cheap gallons, emptied all the water out threw it in. I had some 1/8 npt holes that were where the old steam vents went to. well i just put a couple pushlok fittings in them and made a little loop from 1/4 poly tube to seal them up (didnt have 1/8 plugs). just for the hell of it i messed with that a little just trying to make sure everything was bled out of the block and after messing with it noticed it would leak. took that junk out and put some plugs in. then i also put in a temp hose from the radiator upper most port to my existing expansion tank, but kept it below the coolant level so it could bleed air out and just suck coolant if it wanted to. just drilled a hole in the bottom of it and threw in a fitting since im swapping it out anyway.

    threw the cheap 50/50 in there fired it up, let it idle a bit to get the temp up. got up to like 155 after a few minutes . took it out and ran it for over n hour and the hottest it got was like 184* wanted to settle between 170-175* cruising. maybe a touch on the cool side, but not really concerned with mpg n crap. was also "only" about 80* out so a few degrees cooler than i have been dealing with.
     
  9. Sam Harris

    Sam Harris Full Access Member

    Posts:
    4,034
    Likes Received:
    6,390
    Joined:
    Sep 26, 2018
    Location:
    Denver
    Name:
    Sam
    Excellent!
     
  10. iamdub

    iamdub Full Access Member

    Posts:
    11,658
    Likes Received:
    17,741
    Joined:
    Apr 23, 2016
    Location:
    Li'l Weezyana
    Name:
    Chris
    So what was the root problem, not able to build and hold pressure?
     

Share This Page