Oil Life doesn't reset to 100%

Discussion in 'Engine & Drivetrain' started by SmokChsr, Oct 7, 2018.

  1. SmokChsr

    SmokChsr TYF Newbie

    Posts:
    13
    Likes Received:
    6
    Joined:
    Oct 7, 2018
    Location:
    St Augustine Fl
    Name:
    Alan
    I've tried searching for this, but came up empty so far. So I'm hoping someone here will have an idea.

    For years my 06 Tahoe Z71 4WD 5.3, would properly reset the oil life back to 100%. Now for the last 2 oil changes it has decided that it doesn't want to. On the previous reset attempt it would only reset to 82%.
    On the most recent Oil Change it only reset to 52%. This isn't really a big problem just quite odd.
    I did note that when it only reset to 82% that it still took the same 10K or so miles to get down to 0%.

    Of course when it didn't fully reset the first time I reset it several times all going to only 82%. Now that it's only resetting to 52% I'll have to see how it does.

    I also use the Trip B counter to keep track of mileage between oil changes, so I do have a ready backup.

    I'm now using Mobile1 synthetic oil in the truck and I'm quite comfortable running 10K between changes. For me that's about 3-4 months. I had been running Havoline synthetic, but it became obvious that the shop was either putting the wrong oil in or the Havoline was breaking down at around 5K miles. I notes that around 5K the normal running oil pressure would drop by 10+PSI. Now that I'm using Mobil 1 it remains constant out to 10K.. But that's a story for a different thread.
     
  2. adriver

    adriver Full Access Member

    Posts:
    249
    Likes Received:
    86
    Joined:
    Aug 18, 2018
    Name:
    Justin
    How many miles does she have? Any mods? Is all your other maintenance done on schedule? How do you drive it (aggressive, highway miles, towing, off-road)? What oil are you using (weight and which M1)?



    Just a thought, If you are keeping track of your 10K mile oil changes on your trip meter, here's what I do. ( notepad on my computer)

    228,547 WINDSHIELD REPLACED ($171) SAFELITE (TECHNICIAN-KAI) (08jan2018)
    228,900 SOUND DEADENER INSTALED ON ROOF- DYNAMAT ($148) (25jan2018)
    228,988 MAF CLEANED (02feb2018)
    228,988 CAI CLEANED (02feb2018)
    228,988 THROTTLE BODY CLEANED (02feb2018)
    228,988 THROTTLE BODY TO AIR INTAKE TUBE COUPLING REPLACED K&N KNN-08536 3.75" X 1.75" (02feb2018)
    229,650 ROTATED TIRES front to back, backs crossed to front (06apr2018)
    229,650 OIL CHANGED 5W30 PENNZOIL PLAT FULL SYNTH (06apr2018)


    I also have all my codes listed, and explained. All the parts I have ever bought for it, how much, when they were installed, and broke down by area, Suspension, stereo, etc all broke down in DETAIL, parts I am researching, etc... .. (just offering an unwanted suggestion).
     
    Tonyrodz likes this.
  3. SmokChsr

    SmokChsr TYF Newbie

    Posts:
    13
    Likes Received:
    6
    Joined:
    Oct 7, 2018
    Location:
    St Augustine Fl
    Name:
    Alan
    Well, I would think this has absolutely nothing to do with the oil. Since the oil life condition is simply an electronic algorithm based on driving conditions along with time and mileage to generate a guestimate of the oil condition.

    Now as to answer your question, it's on it's second motor, and has 516K miles. The first motor was replaced at 320K when the O ring on the pick up tube was going bad. Since it's 4WD my mechanic said that they have to pull the motor to change the O ring, and did I want the old one back or just drop in a new Jasper. 5W30 synthetic is the oil. All maintenance is done pretty much on schedule. As far driving mostly non-agressive, road, with some off road.

    Still I don't like to bark up the wrong tree, and I'm thinking this is the wrong tree for this problem. My first though that has no basis in reality, as of yet, is this may be an indication of something like a CMOS battery that's running out of juice in the ECM. The only problem with this is I have no idea if there's even one in there, and if there is one, how it acts at end of life.
     
  4. SnowDrifter

    SnowDrifter Full Access Member

    Posts:
    702
    Likes Received:
    300
    Joined:
    Sep 5, 2016
    Location:
    Wa
    Name:
    Chris

    LOL FUCKING WHAT??????


    Does he know how to remove a differential? FFS you don't even need to fully remove it from the vehicle
     
    HiHoeSilver likes this.
  5. jonnytahoe

    jonnytahoe Full Access Member

    Posts:
    270
    Likes Received:
    19
    Joined:
    Apr 14, 2011
    Location:
    Minnesota
    Name:
    John
    Your ''Mechanic'' sounds like he might want to think about retirement.
     
  6. SmokChsr

    SmokChsr TYF Newbie

    Posts:
    13
    Likes Received:
    6
    Joined:
    Oct 7, 2018
    Location:
    St Augustine Fl
    Name:
    Alan
    I guess the oil pressure reset thing it just a bit too complicated.
     
  7. SnowDrifter

    SnowDrifter Full Access Member

    Posts:
    702
    Likes Received:
    300
    Joined:
    Sep 5, 2016
    Location:
    Wa
    Name:
    Chris
    Oil resets are easy. Tab over to it on your steering wheel controls, hold "enter" until it's reset
     
  8. SmokChsr

    SmokChsr TYF Newbie

    Posts:
    13
    Likes Received:
    6
    Joined:
    Oct 7, 2018
    Location:
    St Augustine Fl
    Name:
    Alan
    Okay.. Gee did we not read the first message? I know How to do the reset, but it won't reset to 100% (currently only to 52%) Hence the reason for the question. PS mine requires that I turn the key on and pump the gas pedal 5 times.. But that's NOT the point.. The point is there is a problem causing it to not reset properly.

    Or said another way, do you really think I'm just now getting around to asking how to reset the frigging oil life after driving it for over 500,000 miles?
     
    Scottydoggs and HiHoeSilver like this.
  9. HiHoeSilver

    HiHoeSilver Away!

    Posts:
    6,250
    Likes Received:
    6,374
    Joined:
    Feb 28, 2017
    Location:
    Chicago
    Name:
    Nate
    Lol.
    Side note :
    Are you sure about the pedal thing? My 06 Z71 all I do is hold the enter button for 5-10 seconds and it reads "reset oil life" . Press enter again to confirm. Weird that they would differ...
     
    Last edited: Oct 9, 2018
  10. Scottydoggs

    Scottydoggs Full Access Member

    Posts:
    1,066
    Likes Received:
    773
    Joined:
    Dec 16, 2017
    Location:
    NJ
    Name:
    Scott
    wheres this energy button? ive got a 05 lt and i'm unfamiliar with that one. i do the key to run, pump the pedal 5 times within a few seconds and its reset like the op's. but mine says 100% afterwards like it should.
     

Share This Page