Odd no start- yet again

Discussion in 'Engine & Drivetrain' started by OneofFew, Jun 8, 2019.

  1. OneofFew

    OneofFew Full Access Member

    Posts:
    204
    Likes Received:
    60
    Joined:
    Jun 25, 2018
    Location:
    Talullah Falls, Ga
    Name:
    Scott
    Gents, it has happened before that for no apparent reason, the engine would fail to start. previously, I was convinced that the fuel pump was not kicking in and messing with the relays for a few minutes would magically solve the problem. I think last time it was over 10 minutes.
    Yesterday evening, I rode up to may neighbors and hours later the truck would not start. This time I did hear the fuel pump, but it still acted like it was starved of fuel. Fuel filter only has 10k miles on it. Having my wife turn the key, off to on, I felt the FP relay clicking in and the usual noises of priming of the fuel rail stuff. It acted like it was starting until I let off the Starter. Giving throttle changed nothing but a bit of raw fuel smell from the exhaust. After 5 mins, we just walked home. This morning the truck started right up on the 1st try.
    I am thinking I have a passlock issue. I do have random 'security' light coming of while driving. The driver door does not light the interior lights. No check engine light.
     
  2. swathdiver

    swathdiver Full Access Member

    Posts:
    9,564
    Likes Received:
    8,484
    Joined:
    May 18, 2017
    Location:
    Treasure Coast, Florida
    Name:
    James
    Tech-2 or bi-directional scan tool in your tool box?
     
  3. OneofFew

    OneofFew Full Access Member

    Posts:
    204
    Likes Received:
    60
    Joined:
    Jun 25, 2018
    Location:
    Talullah Falls, Ga
    Name:
    Scott
    no- but it may have to be in the near future. I was hoping to get a job at the dealership and use their resources, but no go as of yet. The last time i scanned codes, it already had the odd security light behavior, but no related codes.
     
  4. Rocket Man

    Rocket Man Build It Better Supporting Member

    Posts:
    12,429
    Likes Received:
    17,942
    Joined:
    Dec 25, 2014
    Location:
    Oregon
    Name:
    Mark
    Passcode generally lets you start it up but dies in a few seconds.
     
    OneofFew likes this.
  5. Z28TWITCH

    Z28TWITCH Member

    Posts:
    83
    Likes Received:
    26
    Joined:
    Sep 18, 2013
    Name:
    Twitch
    I dont have the write up on hand, but Ive fixed a few tahoes/yukons by adding a resistor at the key cylinder.
    When you try to start it does it start and immediately die?
     
  6. Kenneth Cline

    Kenneth Cline TYF Newbie

    Posts:
    1
    Likes Received:
    0
    Joined:
    Dec 14, 2019
    Name:
    Kenneth
    I have a 2009 Chevy Silverado 1500 hybrid and it will not start. had the little battery checked and it was bad so I replaced it but still will not start. Have it at dealer and they are not sure what the issue is does anyone have a idea of what it could be. Dealership says the hybrid battery is ok but they have had it for two weeks with still not idea as to what is wrong any suggestions
     
  7. PNW VietVet

    PNW VietVet Full Access Member

    Posts:
    2,992
    Likes Received:
    1,432
    Joined:
    Oct 8, 2014
    Location:
    Oregon
    Name:
    Ron
    So, in the older post it was a crank and no start condition. Now with your problem, #1-It is posted in the wrong forum and #2- you make it sound like a no crank condition when you change the battery. Can you please share if it is a crank over and no start or a no engine crank problem?

    Welcome to the forum and complete info will always expedite help.
     
  8. Rocket Man

    Rocket Man Build It Better Supporting Member

    Posts:
    12,429
    Likes Received:
    17,942
    Joined:
    Dec 25, 2014
    Location:
    Oregon
    Name:
    Mark
    That was his first post ever, there wasn’t an older one. This isn’t the OP for this thread so maybe you got confused? But yes, all he said is it won’t start.
     
  9. PNW VietVet

    PNW VietVet Full Access Member

    Posts:
    2,992
    Likes Received:
    1,432
    Joined:
    Oct 8, 2014
    Location:
    Oregon
    Name:
    Ron
    That's why I said, "now with your problem". I said that because I knew he was not the OP. I did not get confused and quit trying to figure me out. We have had our differences before and I am past that but now you start again. We are talking about someone who posts 6 months later on a thread for NBS and my response was to a guy with a NNBS. The OP was very clear about crank and no start since he thought it could be fuel pump related. He also said it acted like it was going to start till he let off the starter. The new respondent talked about a possible battery problem but he was not clear and that is why I asked him what I did. I get context. I also know it was his first post ever because his post count says #1.
     
  10. Rocket Man

    Rocket Man Build It Better Supporting Member

    Posts:
    12,429
    Likes Received:
    17,942
    Joined:
    Dec 25, 2014
    Location:
    Oregon
    Name:
    Mark
    Oh yeah, the politics thing. Anyway, I wasn’t trying to “figure you out”. Sorry if I offended, I was actually trying to help. Turns out it was me who was confused by your post, not you who was confused. Apologies. Calm down, sheesh. Peace.
     

Share This Page