Need help with prolonged cold start...

89Suburban

Bull in the china shop
Joined
Jan 10, 2013
Posts
7,120
Reaction score
16,956
Location
SE PA
Did you by any chance have a strong fuel smell aside from the long crank?


I had a bad fuel smell but no leaks at all, even had it up on a lift looking for a leak with another mechanic. I finally stuck my cell phone above the tank to get pics and I saw the rusted pump lines and fuel. But wasn't leaking enough to run down the side of the tank. These tanks have a sump built in around the top of the tank in that area so it can't drain well. IMHO that is what helps these to rust out in the first place, take a look:



9E21B8EA-EBBF-4E64-BCDC-D4EC20F6A383.jpeg
 

dark_knight

TYF Newbie
Joined
Aug 17, 2014
Posts
14
Reaction score
1
I had a bad fuel smell but no leaks at all, even had it up on a lift looking for a leak with another mechanic. I finally stuck my cell phone above the tank to get pics and I saw the rusted pump lines and fuel. But wasn't leaking enough to run down the side of the tank. These tanks have a sump built in around the top of the tank in that area so it can't drain well. IMHO that is what helps these to rust out in the first place, take a look:



View attachment 377148
Thanks! I just started noticing a bad fuel smell on my car. No leaks and can't see above the tank to see the sending unit.
 

89Suburban

Bull in the china shop
Joined
Jan 10, 2013
Posts
7,120
Reaction score
16,956
Location
SE PA
Thanks! I just started noticing a bad fuel smell on my car. No leaks and can't see above the tank to see the sending unit.


Yeah it was really frustrating to find. You can't get your hands in there to feel. I jacked the rear of the truck up and climbed up over the axle with a shop light and took pics with the phone.
 

dark_knight

TYF Newbie
Joined
Aug 17, 2014
Posts
14
Reaction score
1
Ha ha. I didn't do it. Too busy with working 16 hour days. The guy that did it told me he did have problems removing the lines though.
 

dark_knight

TYF Newbie
Joined
Aug 17, 2014
Posts
14
Reaction score
1
Ha ha. I knew my car was a flex based on the emblem on the back. Never did put e85 in it yet. It is a 2011.
 
Top