Low side service port leaking, bubbles of oil.

olliec420

Member
Joined
Apr 12, 2016
Posts
65
Reaction score
27
So my a/c is leaking at least out of the low side service port. I am planning on fixing. I have the vacuum pump and gauges. Im going to replace the service shrader valves and pull vacuum and recharge. My question is how much (by weight) refrigerant do I put it in it? I have been unable to easily find the amount searching around for a 98 Yukon WITHOUT rear air. Im assuming it would be the same as any 98 silverado/sierra, can anyone provide me the amount of refrigerant by weight please? Also, see the attached media file. You can see the oil bubbling out of the leak. Is that a concern? Does oil need to be added? I dont want to add too much of course. Any input from some experienced a/c folks?

EDIT: click on the this image and watch the video on imgur. should the oil be bubbling there? should it be at that point in the system or only in the compressor?
 
Last edited:

George B

I like cheese.
Joined
Feb 5, 2020
Posts
6,220
Reaction score
13,437
Location
Wisconsin
 
OP
OP
olliec420

olliec420

Member
Joined
Apr 12, 2016
Posts
65
Reaction score
27
Thanks for that!
 

east302

Full Access Member
Joined
Dec 21, 2016
Posts
1,280
Reaction score
852
Location
Mississippi
Images from a 98 manual are below, maybe it will help on the oil. Full manuals for most years can be downloaded here:


7220CADF-75AC-4174-8FA6-EF2DF81EAC22.jpeg

3228EC5A-0409-4CEA-966E-9424CBCE1A69.jpeg
 

Snowbound

Jim
Joined
Nov 23, 2016
Posts
991
Reaction score
2,242
Location
Chicagoland (Lockport)
I wouldn’t add any oil if your not replacing accumulator or compressor. Only time I add oil is when I know the system is completely clean from flushing and I’m replacing hard parts.

Most compressors, if not all, come with oil in them. And after new compressor install you should always put vacuum on system to make sure there are no leaks. When you do that, you don’t have to add any more oil. That should tell ya that you will not vacuum out the oil. All the vacuum pump does is put system on a negative pressure. If you were to open one end and vacuum the other you could possible pull the oil out but I wouldn’t worry about the PAG oil. Just make sure it holds vacuum for 20 minutes at a minimum and put your freon in and you’re good to go.
 

Eman85

Full Access Member
Joined
Apr 18, 2021
Posts
146
Reaction score
100
One of those links is to my thread about refrigerant capacity. The 2.25lbs worked great on the Tahoe with C60 frt. AC only. I would add some flourescent dye when I charged it for future leak detection. Compressors are notorious to leak. If the system is empty you might want to replace the orifice tube, it will give you a good indication of compressor condition. If you find debris on the screen you might be in for a compressor replacement soon.
 
OP
OP
olliec420

olliec420

Member
Joined
Apr 12, 2016
Posts
65
Reaction score
27
One of those links is to my thread about refrigerant capacity. The 2.25lbs worked great on the Tahoe with C60 frt. AC only. I would add some flourescent dye when I charged it for future leak detection. Compressors are notorious to leak. If the system is empty you might want to replace the orifice tube, it will give you a good indication of compressor condition. If you find debris on the screen you might be in for a compressor replacement soon.
Helpful. I bought 4 cans of r134a and one with the dye. The compressor is a replacement but I don't know when it was replaced. I'll look in to the orifice replacement too. Thanks.
 

Forum statistics

Threads
121,107
Posts
1,674,858
Members
82,283
Latest member
jsymol
Top