Just Fishing's 09 Tahoe Build thread

iamdub

Full Access Member
Joined
Apr 23, 2016
Posts
14,136
Reaction score
24,605
Location
Li'l Weezyana
Kinda what i was originally thinking.
I have a set of 7.4s, but they did pump metal.

Hoping it's just the valve cover.
Things came up, so I'm hoping to tackle the job tomorrow....

They're just metal tubes. There's nothing to be affected if tiny metal particles went through them. But, if the ball tips are scored, then they're junk. If just polished and not bent, they're good.
 

Just Fishing

Full Access Member
Joined
Aug 30, 2020
Posts
1,437
Reaction score
3,208
Location
Utah
They're just metal tubes. There's nothing to be affected if tiny metal particles went through them. But, if the ball tips are scored, then they're junk. If just polished and not bent, they're good.

They are pretty much polished tips :cheers:
 

Just Fishing

Full Access Member
Joined
Aug 30, 2020
Posts
1,437
Reaction score
3,208
Location
Utah
got something new last night
P1400
Apparently it's related to the expected airflow vs what was detected during cold start.

I'm assuming there is another table that i need to copy over.
I did copy over the cat heating table...
:fishing1:

or the other thing, but we don't talk about fight club.
You must be logged in to see this image or video!

(Off switch)

;)
 

08z71bgm

Supporting Member
Joined
Jul 2, 2020
Posts
669
Reaction score
962
Location
Long Island, NY
got something new last night
P1400
Apparently it's related to the expected airflow vs what was detected during cold start.

I'm assuming there is another table that i need to copy over.
I did copy over the cat heating table...
:fishing1:

or the other thing, but we don't talk about fight club.
You must be logged in to see this image or video!

(Off switch)

;)
Yeah because it needs a proper tune. What did you change from the original tune?
 

Just Fishing

Full Access Member
Joined
Aug 30, 2020
Posts
1,437
Reaction score
3,208
Location
Utah
The original trailblazer ss tune, it still has the same fueling stuff from the first run.
But it does have that timing map from the 2500hd.

I'll look at putting the trailblazer ss timing map back for now.
Just the 2500hd is so much smoother.
Only real difference is the higher revs.

I have been thinking about a hybrid between the two.
Just knock down that higher load stuff pretty much.

But the hoe has been benched for now, it's clearly not ready for longer drives until it's 100%

As for knock count checks, so far it's a draw between the tech2 and hp tuners.

Hp tuners is nice because of tue smaller dongel.

Tech2 sticks out and i have to be careful when driving.
I managed to bump it and caused a disconnect...
 

Just Fishing

Full Access Member
Joined
Aug 30, 2020
Posts
1,437
Reaction score
3,208
Location
Utah
Oh one other thing i changed.
The volume of the intake.
The trailblazer ss had a different volume than what the 5.3 had.
I thought the ss had the same intake, but now I'm not totally sure.

I can try flipping the value back to see if it helps.

But it took several days to get that p1400 to pop up.

Maybe because of the cold starts, i didn't allow it to warm fully because of shuffle cars around.

Focus has shifted to the wifes car.
Routed a drain tube for her catch can.
And i have been flushing fluids, transmission for now.
Next brakes and power steering fluid.

I also found her car had the original battery!
I started noticing a slower sounding start here and there.
So i popped the battery access hatch, found an ac delco battery with no date codes.
So i texted the original owner that we bought it from, sure enough.
Original!

10 year old battery!!
So she got a new one from costco for good measure.
 

Just Fishing

Full Access Member
Joined
Aug 30, 2020
Posts
1,437
Reaction score
3,208
Location
Utah
Well, i did some timing adjustments in the tune.
Reduced the overall timing in the 10 degree and over cells by a few points in the high octane.
Really reduced timing in the low rpm high load table.
(500-1000 rpm)

And the high load timing jump, i made that a little shorter, reducing timing for high load overall.

Then went through the low octane timing and matched thst up, and using another timing table to match up the expected timing reduction.
Then knocked a good 5-10 degrees from that.

Seems to run fine, but my low rpm torque sure suffered!

Doing a little logging with the tech2, im no longer seeing that 2 degree of timing retard.
And the misfire map looks clean.

For now it's good enough to drive around town should i need to.
But i have a set of new oem nb O2 sensors on order.

And while I'm in there, it's getting a wideband.

I do worry about the wb being right at the exit of the cat.
I have issues just with the long tubes in the ol vette, those things can be a bit fragile.
And about $80 a pop.

For the hoe, i still might just have an o2 bung installed before what i think is the middle cat.
 

cooki3mnster

Member
Joined
May 24, 2021
Posts
79
Reaction score
116

Forum statistics

Threads
114,111
Posts
1,555,524
Members
72,300
Latest member
Humphrey
Top