Help with 2014 Yukon

mandop86

TYF Newbie
Joined
Jul 25, 2021
Posts
2
Reaction score
3
Im having some serious electrical issues or something with 2014 Yukon xl. Abs light flashes then stabilitrak and traction light comes on then goes away either when I come to a complete stop or when I accelerate. Also now every gauge zeros out and dash goes black and all the door locks start unlocking and locking continuously. Acts like the transmission is slipping and revs high and won’t go into next gear. But I know it’s something electrical

You must be logged in to see this image or video!
 

swathdiver

Full Access Member
Joined
May 18, 2017
Posts
13,766
Reaction score
15,079
Location
Treasure Coast, Florida
Im having some serious electrical issues or something with 2014 Yukon xl. Abs light flashes then stabilitrak and traction light comes on then goes away either when I come to a complete stop or when I accelerate. Also now every gauge zeros out and dash goes black and all the door locks start unlocking and locking continuously. Acts like the transmission is slipping and revs high and won’t go into next gear. But I know it’s something electrical

You must be logged in to see this image or video!
You might have bad grounds and or battery cables or the battery itself may need changing. A battery that passes tests and still has a bad cell in it can wreak all kinds of havoc on the electrical system on these trucks. Nice looking truck and welcome to the forum.
 

PNW VietVet

CCW
Supporting Member
Joined
Oct 8, 2014
Posts
10,620
Reaction score
11,404
Location
LIMBO
Read thru this and look for the grounds problems. Many many many threads on here about electrical gremlins and ground problems causing many things. Especially if you live in an area where there is salt on the roads in winter and the corrosion/rust causes problems.


Or as @89Suburban and @swathdiver said, engine problems, limp in mode and battery cables/battery problems.

Oh, also, welcome to the forum from Oregon.
 

Joseph Garcia

Supporting Member
Joined
Aug 2, 2018
Posts
2,750
Reaction score
3,259
Welcome to the Forum from NH.

Lots of knowledgeable folks here who freely share their knowledge, experiences, and perspectives. Knowledge is power.

I hope that you will become a participating member in the Forum's discussions.

Knowledgeable folks on this Forum are already giving you advice on what to check out with your issue. All ground connections (battery, engine, and chassis) should be checked and cleaned as needed.
 

mandop86

TYF Newbie
Joined
Jul 25, 2021
Posts
2
Reaction score
3
Thanks everyone I took the truck to my personal mechanic and he performed just a standard inspection of all the grounding and battery connections and cabling and nothing was found. Ended up taking to the dealership and so far they found an “open short” for the air bag system to one of the control modules but after inspecting the harnesses haven’t found anything. They kept it overnight and still waiting for determination of what it can be but might have to take it to GMC if it’s not resolved.
 

Forum statistics

Threads
114,191
Posts
1,556,518
Members
72,438
Latest member
scruffy
Top