Headlight issues. Plz help. I got my 96 tahoe running today after replacing the starter. No headlights, i tapped on each, right came on but not left.

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

nite202

TYF Newbie
Joined
Sep 12, 2023
Posts
1
Reaction score
0
Got my 96 running today. Replaced starter, been sitting a year. Low beams wouldn't come on till I tapped, right came on. Now, no lights, high beam indicator stays on, switch won't shut it off, no headlights. I don't feel any detent in switch now but did earlier.
Thoughts, please? Thanks.
 

Joseph Garcia

Supporting Member
Joined
Aug 2, 2018
Posts
5,537
Reaction score
6,972
Welcome to the Forum from NH.

Lots of knowledgeable folks here who freely share their knowledge, experiences, and perspectives. Knowledge is power.

I hope that you will become a participating member in the Forum's discussions.

Pics of the truck, please.

You are already receiving clarifying questions from the knowledgeable folks on this Forum.
 

OR VietVet

Multnomah Falls
Supporting Member
Joined
Oct 8, 2014
Posts
17,345
Reaction score
26,590
Location
Willamette Valley
If has been sitting for a year, may have critter chew problems. Remove headlights and check all connections and grounds. Your headlights have power even when engine is shut off. You need to remove the headlight switch and inspect the back of it too. I had an older Chevy truck that would shut off normally in the daytime but when driving with lights on and shut off engine, the engine would not stop running till turned headlights off. The back of fuse panel had headlight wire insulation rubbed thru and supplied ignition power.
 

Eman85

Full Access Member
Joined
Apr 18, 2021
Posts
283
Reaction score
353
Got my 96 running today. Replaced starter, been sitting a year. Low beams wouldn't come on till I tapped, right came on. Now, no lights, high beam indicator stays on, switch won't shut it off, no headlights. I don't feel any detent in switch now but did earlier.
Thoughts, please? Thanks.
No detent in the dimmer switch could be a big clue. Try a test light at the headlamp connector and see if you have power then see if you have ground. If one or both are missing work backwards from there.
 

Forum statistics

Threads
125,972
Posts
1,758,159
Members
87,884
Latest member
REYAUTO1

Latest posts

Top