Has anyone experienced this engine noise '21 or '22?

mb1500

Full Access Member
Joined
Jan 22, 2019
Posts
243
Reaction score
191
@Z7122 , what is the DFM that you're referring to? I tried L9, and like you, the noise disappears. I am by no means well versed in the technical or mechanical aspects here. I'm struggling to understand why the injectors would make the noise in Drive, but not in L mode. Also trying to figure out how to make the dealer understand and agree to diagnose and correct it.

@Doubeleive , I don't know what made me ask if it would shift through the gears normally. I guess because I had never tried L mode on this vehicle. It was a stupid question, LOL.

In older models going back to the 6 speed I believe, tow/haul or M5 disables the AFM on earlier models and it seems that M9 will disable DFM on 21+.

If the noise goes away when in L9 and not in D and the noise is most likely associated with the DFM system. This system shuts off cylinders at will and can run on any combination of the 8 cylinders because all of them are setup this way.
 

chrisgiles

TYF Newbie
Joined
Sep 8, 2022
Posts
4
Reaction score
0
Interesting regarding the DFM...I wonder if there's a way to permanently disable that, and if the dealer would be willing to do it (I doubt it).
 

WalleyeMikeIII

Full Access Member
Joined
Feb 22, 2022
Posts
901
Reaction score
588
Location
Sunny and Snowy Minnesota
In older models going back to the 6 speed I believe, tow/haul or M5 disables the AFM on earlier models and it seems that M9 will disable DFM on 21+.

If the noise goes away when in L9 and not in D and the noise is most likely associated with the DFM system. This system shuts off cylinders at will and can run on any combination of the 8 cylinders because all of them are setup this way.
Tow/Haul did not disable AFM on my 2013 Suburban...often it would go to V4 mode when coasting into town and my boat behind me.
 

Blackcar

Full Access Member
Joined
Mar 31, 2018
Posts
326
Reaction score
233
Interesting regarding the DFM...I wonder if there's a way to permanently disable that, and if the dealer would be willing to do it (I doubt it).
It's just mechanical work and it has nothing to do with emissions and if vehicle is out of warranty, they probably would do it for so much an hour, but you can probably find a good mom and pop shop that would do at a better price
 

mb1500

Full Access Member
Joined
Jan 22, 2019
Posts
243
Reaction score
191
Tow/Haul did not disable AFM on my 2013 Suburban...often it would go to V4 mode when coasting into town and my boat behind me.

Interesting, I thought the tow/haul disabled it but wouldn’t know. I always get it disabled via tune.
 

Erik23

TYF Newbie
Joined
Jul 11, 2021
Posts
29
Reaction score
13
I just had my wife’s 22 Denali 6.2 in for the exact same issue. It also makes the same noise on cold start, especially when you put it into gear. Dealers hears the sound but after having the car for 5 days says they talked to gm and they advised it’s normal and there is nothing to fix. This is insane!
 

Rickd11

TYF Newbie
Joined
Jan 25, 2022
Posts
6
Reaction score
1
I just had my wife’s 22 Denali 6.2 in for the exact same issue. It also makes the same noise on cold start, especially when you put it into gear. Dealers hears the sound but after having the car for 5 days says they talked to gm and they advised it’s normal and there is nothing to fix. This is insane!
Same thing happened to me. For the first 1500 miles it didn't make any noise on cold start, then I started noticing it a little, kinda like a belt or pulley or exhaust leak. I can't put my finger on it. But it's progressively gotten louder to the point where it's embarrassing to start out in public now. Dealer says it's normal operation. It's ridiculous.
 

0x_2a

TYF Newbie
Joined
Sep 26, 2022
Posts
1
Reaction score
0
My brand new 23 Yukon Denali Ultimate has this sound. Asked about it on the lot, they said they all do that under 1500 RPM. Slightly jerky 2nd gear on acceleration too (pedal 30-40% down). Will poke around, sounds more like exhaust system than belts to me.
 

ACCER123

TYF Newbie
Joined
Sep 13, 2021
Posts
5
Reaction score
0
I have a 23 Suburban 5.3. Recently start to notice the same sound from the op video when the truck drop speed to approximately 15mph, couldn't make out what is it yet
 

chrisbusnut

TYF Newbie
Joined
Jul 29, 2022
Posts
1
Reaction score
1
I've been driving in L9 for the past few months, and there is no noise unless I forget to manually switch to L9 and leave it in drive. It's a pain to have to repeatedly press the L and then + buttons until I'm in 9th gear each time I switch into Drive, but it's better than hearing the injector noise. So it must be related to the cylinder deactivation feature. I agree that it's embarrassing, not to mention extremely frustrating and disappointing, especially considering what I spent on this vehicle.
 

Forum statistics

Threads
121,107
Posts
1,674,872
Members
82,283
Latest member
jsymol
Top