Cluster Flicker

Discussion in 'Interior' started by RVATahoe, Jul 18, 2018.

  1. RVATahoe

    RVATahoe TYF Newbie

    Posts:
    13
    Likes Received:
    0
    Joined:
    Nov 10, 2015
    Name:
    Stef
    2006 Tahoe Z71 Cluster lights sometime wont illuminate when starting the truck and or cutting on the lights. I have to literally wack :chair: the dash board a few times for it to cut on... Any reason why? How to fix? Should I just update the cluster? Needs a refresher anyway. Any links or people on here that update the cluster? Any advice will help.

    Thx in advance
     
  2. HiHoeSilver

    HiHoeSilver Away!

    Posts:
    5,942
    Likes Received:
    6,112
    Joined:
    Feb 28, 2017
    Location:
    Chicago
    Name:
    Nate
    I would take a good look at the harness connectivity for the cluster. You got questions about custom rebuilds, you ask @ScottyBoy.
     
  3. Bigbeardenali1992

    Bigbeardenali1992 Full Access Member

    Age:
    26
    Posts:
    3,693
    Likes Received:
    2,940
    Joined:
    Feb 16, 2015
    Location:
    Big Bear Lake, ca
    Name:
    Chase
    Look at the cluster connection first like he said^. If that’s secure, then take a look at your dimmer wheel switch. The 2005 Escalade esv that belong sto the family I share a house with had the same issue you’re talking about. It wold flicker over a bump, sometimes not turn on until you hit it or a bump. He replaced the dimmer wheel/headlight control switch and so far it seems to have fixed the problem.
     

Share This Page