2022 speed limit blank

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Dustindu4

Full Access Member
Joined
Oct 14, 2021
Posts
106
Reaction score
40
Location
Salem, NH
I've got a 2022 Yukon and the speed limit on the HUD has always been blank. I have the full onstar and data package enabled and it doesn't work. What am I missing?
 

Blueinterceptor

Full Access Member
Joined
Jan 20, 2016
Posts
911
Reaction score
511
Have you tried to center the display? Or gone through the menu for the display options
 

CoryS

Member
Joined
Aug 23, 2021
Posts
41
Reaction score
18
Has anyone figured out how to fix the missing speed limit number in the HUD and instrument cluster on a 2022 Yukon? I am having the same issue. It just shows a white speed limit sign with no numbers. Thanks.
 

NathanSMSU

TYF Newbie
Joined
Mar 26, 2016
Posts
26
Reaction score
29
Had same thing occur on my 2022 highcountry. I found this in the owners manual - "Speed Sign : Shows sign information, which comes from a roadway database in the onboard navigation system, if equipped. The sign will show “− −” when offline maps are unavailable". If you go into Google Maps...settings...you should see something on downloading offline maps. After this mine showed backup. Interesting side note...if you have multiple profiles (like husband/wife) you will have to download the offline maps for each profile.
 
OP
OP
D

Dustindu4

Full Access Member
Joined
Oct 14, 2021
Posts
106
Reaction score
40
Location
Salem, NH
I called onstar and was transferred to tech support. Tech support said I needed to be transferred to GM and then onstar hung up on me. Then like 3 days later it started working on its own. Most of the time.
 

CMoore711

Full Access Member
Joined
Jul 18, 2017
Posts
1,047
Reaction score
769
60% of the time it works 100% of the time
 

Attachments

  • C6C2D692-B0B8-4A91-92D1-B1513FF0A494.jpeg
    C6C2D692-B0B8-4A91-92D1-B1513FF0A494.jpeg
    827.9 KB · Views: 10

bam01

TYF Newbie
Joined
Sep 3, 2021
Posts
21
Reaction score
17
Same here it works one drive then another it doesn’t…
 

Dewally

TYF Newbie
Joined
Feb 18, 2022
Posts
21
Reaction score
12
Location
Alabama
Same issue here. I did not give Google permissions for my location. I use Apple CarPlay. I have been wondering if that may be the cause of the issue.
 

Forum statistics

Threads
125,972
Posts
1,758,126
Members
87,881
Latest member
gtribble3
Top