2011 Tahoe - No Rear Air Flow

Discussion in 'Interior' started by David W, Feb 13, 2020.

  1. David W

    David W TYF Newbie

    Posts:
    2
    Likes Received:
    0
    Joined:
    Feb 13, 2020
    Name:
    David
    My rear vents don't blow hot or cold but the blower motor is running. I haven't done a ton of research but I don't think these models have a rear cabin air filter (I thought maybe it could be clogged). What else could be causing no airflow even though the blower appears to be blowing?
     
  2. David W

    David W TYF Newbie

    Posts:
    2
    Likes Received:
    0
    Joined:
    Feb 13, 2020
    Name:
    David
    bump, any thoughts?
     
  3. kbuskill

    kbuskill ***CAUTION*** I do my own stunts!

    Posts:
    3,534
    Likes Received:
    4,462
    Joined:
    Mar 11, 2017
    Location:
    NE. FL.
    Name:
    Ken
    Perhaps some of the ducting leading from the blower motor in the rear to the roof vents became disconnected.
     
  4. wjburken

    wjburken Supporting Member

    Posts:
    2,394
    Likes Received:
    3,728
    Joined:
    Dec 26, 2017
    Location:
    Eastern Iowa
    Name:
    Wade
    You said the blower motor is running. Is that because you hear it running or you have see it running? You may have a locked up blower fan and you are hearing the motor humming trying to turn it or the blower fan came off the armature of the motor and the motor is spinning nothing.

    As Ken suggests, follow the path from the blower and go until you find where the air isn’t moving anymore, but first confirm that the blower is in working order.
     
    kbuskill likes this.

Share This Page