2007 Tahoe introduction thread

Trilla_one

TYF Newbie
Joined
Oct 16, 2021
Posts
4
Reaction score
7
Hello people. Just picked up an 07 with 206,000 miles. Being the biggest vehicle I ever had it's been an adjustment getting used to it but I'm loving it. It actually fits me the best since I'm 6'2.5 215lbs.

I got it with a few mods already done. 22 x 9.5 Noir wheels, debadged sides, color matching all around, black bowties, some kind of exhaust upgrade as it sounds louder and deeper than stock, high flow air filter, and led lights inside and out. Things done by me so far are a new set of tires and complete 3000 watt stereo overhaul. Will be blacking out the trim of the grill except for the trim around the bowtie next.

Only issues so far are a sporadic check engine and stabilitrack off lights. From my research they seem to be related to a loose gas cap (which I already replaced) and the maf sensor. Besides that the ride is a little bumpy and I'm not sure if it's something to do with shocks since it was happening before and after the new tires and two balancings. Reminds me of a car lowered on stiff coilovers. Not a huge deal just kind of annoying. Will see how that goes.

All in all looking forward to learning from and sharing with the community. Peace



You must be logged in to see this image or video!
You must be logged in to see this image or video!
You must be logged in to see this image or video!
You must be logged in to see this image or video!
 

avalonandl

Full Access Member
Joined
Apr 6, 2019
Posts
1,873
Reaction score
2,126
Location
Troy, MICH & Naples, FL
Make sure your battery connections are good, stabilitrak warnings CAN be a sign of bad battery cables. Ur at the right age/,mileage.

Welcome BYW
 
Last edited:

wsteele

Full Access Member
Joined
Dec 26, 2020
Posts
1,631
Reaction score
2,198
At some point you will want to determine if you have the upgraded bank 1 valve cover. This upgrade entails a revised vent setup for the PCV and can greatly impact oil consumption. If you do a search on GM AFM Oil Consumption TSB, it outlines what the problem and fixes are, just FYI.

Something you can do do take a look at the oil use profile pretty quickly is pul the number 7 spark plug. If it looks nice and grey/tan and not all junked up with a ton of ash that looks like something out of the movie Alien, then you likely have the updated valve cover.

In any case, a really nice upgrade is an oil catch can installed between the PCV and the intake manifold will tell you a lot about how much oil is being pumped up through there and also will help in separating whatever oil is in the vapor stream before it gets back into the engine. There are a few threads in these forums on the best catch cans and how to install them.

Good luck, have fun.

P.S. - the Stabilitrak off comes on for a lot of reasons unrelated to traction, wheel speed, etc. If you have a persistent miss in the engine it can light up the Stabilitract message as well. Maybe check the "Tech 2 Owners" sticky above and see if anyone close to you has a Tech 2. It is what the factory uses to debug these trucks and is a very powerful tool. If someone isn't close, maybe learn about getting one yourself, it is a very useful scan tool.
 

Trilla_one

TYF Newbie
Joined
Oct 16, 2021
Posts
4
Reaction score
7
Thanks for the welcome and useful tips. Not sure why this got moved to the engine and drivetrain section. Issues I mentioned were just part of my general introduction.
 
Last edited:

Trilla_one

TYF Newbie
Joined
Oct 16, 2021
Posts
4
Reaction score
7
Make sure your battery connections are good, stabilitrak warnings CAN be a sign of bad battery cables. Ur at the right age/,mileage.

Welcome BYW

P.S. - the Stabilitrak off comes on for a lot of reasons unrelated to traction, wheel speed, etc. If you have a persistent miss in the engine it can light up the Stabilitract message as well. Maybe check the "Tech 2 Owners" sticky above and see if anyone close to you has a Tech 2. It is what the factory uses to debug these trucks and is a very powerful tool. If someone isn't close, maybe learn about getting one yourself, it is a very useful scan tool.
I will keep those things in mind. I recently replaced the battery with a new one and connections checked out ok. I do notice the light comes on less frequently now and usually only pops up briefly in a cold shift from 1st to 2nd, which also feels harder, almost like bucking into gear.

My reason for thinking it has to do with the MAF is from watching this guys YT video.
You must be logged in to see this image or video!
I should also add that the previous owner installed a K&N air intake. Unsure when was the last time the filter was serviced.
 

Trilla_one

TYF Newbie
Joined
Oct 16, 2021
Posts
4
Reaction score
7
I may post this question in the vehicle interface section but trying here first. After installing the new radio and interface the backup assist and passenger auto mirror tilting aren't functioning properly. The back up assist no longer goes past the first amber warning light when backing up no matter how close I get to anything, and the passenger mirror tilts up instead of down when I shift into reverse(driver still shifts down). I went ahead and turned off the passenger side until I get it figured out. I brought it back to the shop that installed the radio and interface and they said these issues have nothing to do with the interface. I think otherwise but don't know enough about it to call them out. These aren't huge inconveniences and I only recently got used to them but they do make the driving experience more pleasant. Any ideas?

A few pics from the past week:

You must be logged in to see this image or video!
You must be logged in to see this image or video!
You must be logged in to see this image or video!
You must be logged in to see this image or video!
You must be logged in to see this image or video!
 

Forum statistics

Threads
115,379
Posts
1,574,997
Members
74,958
Latest member
Bigjames

Latest posts

Top