'08 yukon wipers keep running, and Cruse control

Discussion in 'Site News' started by Togo08, Oct 20, 2019.

  1. Togo08

    Togo08 TYF Newbie

    Posts:
    6
    Likes Received:
    1
    Joined:
    Apr 18, 2012
    Name:
    Bob
    My '08 Yukon's wipers keep running even when the car is turned off.
    This happened because the wipers were frozen to the windshield. I have the fuse removed now to keep them from constently running.
    I have replaced the multi switch on the column and the wiper motor to no avail.
    The dealer thinks it may be the fuse block, I think I heard that before here.
    Any suggestions?

    Also the cruse control gradually quit working. I read here that it may be because of the brake rod not retracting far enough and that makes the system think the brakes are on, diabelling the cruse. Started when it was cold, but now dosn't work at all.
    I lubricated the rod and slit it, that didn't seems to help, at least not for long.
    Again the dealer is lost.

    Any help would be appreciated!!
    Thanks, Bbo
     
    ascotell likes this.
  2. wjburken

    wjburken Full Access Member

    Posts:
    1,203
    Likes Received:
    1,635
    Joined:
    Dec 26, 2017
    Location:
    Eastern Iowa
    Name:
    Wade

    Not sure how wipers getting frozen would cause the wipers to run continuously. It would more likely cause a fuse to blow as the motor tries to move the wipers. The fuse block under the hood can get corrosion under it and cause things to act weird. I had headlights that would turn off unless I pulled the fuse and a horn that wouldn’t stop unless I pulled the fuse.

    As for the cruise, the common issue is the brake switch that senses when you press the brake pedal. It’s a $20-$25 part and takes about 10-15 minutes to swap out.
     
  3. Togo08

    Togo08 TYF Newbie

    Posts:
    6
    Likes Received:
    1
    Joined:
    Apr 18, 2012
    Name:
    Bob
     
  4. Togo08

    Togo08 TYF Newbie

    Posts:
    6
    Likes Received:
    1
    Joined:
    Apr 18, 2012
    Name:
    Bob
    That was my idea on the cruse.
    I think that the wipers overheated something causing a constantly closed curcuit. It used to be a part in the wiper motor system, but tht has been changed in the new wiper motors. So, it appears it went to the next weakest link.
     
  5. wjburken

    wjburken Full Access Member

    Posts:
    1,203
    Likes Received:
    1,635
    Joined:
    Dec 26, 2017
    Location:
    Eastern Iowa
    Name:
    Wade
    Here is a link to the brake switch that I think you need.

    https://www.amazon.com/ACDelco-D1539J-Original-Equipment-Switch/dp/B001KSGJKQ
     
  6. Mechanic421

    Mechanic421 06 Denali XL

    Posts:
    119
    Likes Received:
    58
    Joined:
    Oct 16, 2016
    Location:
    Statesville North Carolina
    Name:
    David
    Scan truck first then go for there.
     
  7. Togo08

    Togo08 TYF Newbie

    Posts:
    6
    Likes Received:
    1
    Joined:
    Apr 18, 2012
    Name:
    Bob
    OK, I'll talk to them.
     

Share This Page