06 Denali surging/rough idle

Discussion in 'Engine & Drivetrain' started by MurdrNali, Sep 4, 2013.

  1. MurdrNali

    MurdrNali TYF Newbie

    Age:
    31
    Posts:
    27
    Likes Received:
    0
    Joined:
    Jun 24, 2013
    Location:
    Blue Springs, MO
    Name:
    Colby
    Hey guys, my denali has started idling kinda rough lately. It's weird though because it will be fine then surge almost like it has a cam in it then be fine then surge. It does this off and on several times while idling at a stop light or while in park. My first thought was fuel pump, but I figured it'd be dead by now. Only thing else I can think of is maybe clean the TB and MAF? I'm stumped ohh and no CEL either. Any input is appreciated! Thanks
     
  2. 07Burb

    07Burb GM fan for life Staff Member Supporting Member

    Posts:
    40,247
    Likes Received:
    3,641
    Joined:
    Jan 3, 2011
    Name:
    Jacob
    Do your RPMs fluctuate when this happens as well?
    How old are your spark plugs?
     
  3. MurdrNali

    MurdrNali TYF Newbie

    Age:
    31
    Posts:
    27
    Likes Received:
    0
    Joined:
    Jun 24, 2013
    Location:
    Blue Springs, MO
    Name:
    Colby
    Minimal fluctuations at least in the gauge. I'd say it is fluctuating though because the dome lights will dim when it happens almost like the alternator is "slowing down" and the plugs/wires are less the 3k miles old
     
  4. Rivieraracing

    Rivieraracing Full Access Member

    Age:
    42
    Posts:
    3,811
    Likes Received:
    73
    Joined:
    May 2, 2009
    Location:
    Oregon
    Name:
    Chris
    Yeah man, clean your throttle body and if you want also clean your MAF!! My throttle body will cause that effect when it needs to be cleaned, plus it's a pretty cheap easy try at a fix!
     
  5. livingez_123

    livingez_123 Full Access Member

    Posts:
    1,690
    Likes Received:
    12
    Joined:
    Feb 18, 2013
    Location:
    Portland, OR
    Name:
    Robert
    Ditto..... /\ /\ /\
     
  6. OHSIXX

    OHSIXX Elite Member Supporting Member

    Posts:
    3,764
    Likes Received:
    206
    Joined:
    Jul 15, 2011
    Location:
    Milwaukee
    Name:
    J
    Does it happen with or without the AC on??

    Sounds like a dirty throttle body to me...
     
  7. MurdrNali

    MurdrNali TYF Newbie

    Age:
    31
    Posts:
    27
    Likes Received:
    0
    Joined:
    Jun 24, 2013
    Location:
    Blue Springs, MO
    Name:
    Colby
    It does it with AC on or off. I'm gunna clean the TB tonight and see if that helps thanks everyone!
     
  8. Rivieraracing

    Rivieraracing Full Access Member

    Age:
    42
    Posts:
    3,811
    Likes Received:
    73
    Joined:
    May 2, 2009
    Location:
    Oregon
    Name:
    Chris
    :waytogo:
     
  9. 07Burb

    07Burb GM fan for life Staff Member Supporting Member

    Posts:
    40,247
    Likes Received:
    3,641
    Joined:
    Jan 3, 2011
    Name:
    Jacob
    Another thing you might try is running a bottle of injector cleaner through to get everything cleaned out good.
     
  10. MurdrNali

    MurdrNali TYF Newbie

    Age:
    31
    Posts:
    27
    Likes Received:
    0
    Joined:
    Jun 24, 2013
    Location:
    Blue Springs, MO
    Name:
    Colby
    i ran some seafoam threw it after i replaced the plugs/wires a few months ago, and well, i got sidetracked grilling pork chops and drinking beer tonight so havent had a chance to clean the TB yet lol but when i do ill post back results.
     

Share This Page