02 Z71 Update

Discussion in 'Engine & Drivetrain' started by PNWMuseumman, Nov 6, 2018.

  1. PNWMuseumman

    PNWMuseumman Bow Ties Are Cool Supporting Member

    Posts:
    206
    Likes Received:
    142
    Joined:
    Feb 22, 2015
    Location:
    PNW
    Name:
    Chris
    Hello All!

    After 3 weeks of work (on and off) I finally have my hoe put back together from doing the oil pump / pick up tube o-ring! That pesky life thing kept getting in the way. Found out my wife is pregnant with our second, Super excited! But that also brought on insane morning sickness, so that pumped the brakes on me spending time in the garage wrenching on this thing...

    Down to business... I put in an oem replacement oil pump, changed the O-ring, cleaned the sh*t out of stuff while I was in there.

    Result: I fixed my leaking from everywhere oil pan gasket :) and my oil pressure definitely indicates higher about 40psi crusing on the freeway around 2k rpm. Yayy! And then the tahoe dealt the punch to the throat. My problem continues → engine at operating temperature, come to a stop at a light, oil pressure drops to ZERO and warning light comes on the dash to "Check Engine Oil Pressure"

    :pokeowned:

    I'm pretty sure my dad changed the oil pressure sending unti before I got the car, and he reported that it didn't change the problem, however he didn't know about the screen under the unit until after he was done. Could that screen be the problem? Could it be the sendign unit? Thoughts?


    Thanks!
     
  2. Scottydoggs

    Scottydoggs Full Access Member

    Posts:
    1,020
    Likes Received:
    744
    Joined:
    Dec 16, 2017
    Location:
    NJ
    Name:
    Scott
    if its not ticking and tapping once you get the no oil pressure warning.........the screen under the sensor tends to get clogged up and blocks the flow of oil. so id get in there and change that.
     
  3. PNWMuseumman

    PNWMuseumman Bow Ties Are Cool Supporting Member

    Posts:
    206
    Likes Received:
    142
    Joined:
    Feb 22, 2015
    Location:
    PNW
    Name:
    Chris
    Yeah, there is ZERO change in sound when I get the pressure warning light. No extra ticking or tapping of any kind. How much of a pain is it to get to the sending unit / screen? Can I do it without taking off the plenum thing (The black intake looking thing)?
     
  4. Scottydoggs

    Scottydoggs Full Access Member

    Posts:
    1,020
    Likes Received:
    744
    Joined:
    Dec 16, 2017
    Location:
    NJ
    Name:
    Scott
    i watched a few you tube vids on it a while back. no one really shows them digging it out, but they all left the upper intake on.
     
  5. PNWMuseumman

    PNWMuseumman Bow Ties Are Cool Supporting Member

    Posts:
    206
    Likes Received:
    142
    Joined:
    Feb 22, 2015
    Location:
    PNW
    Name:
    Chris
    where is the screen located? Is it like down in there or is it right there under the sending unit? I just want to have a clear idea before I go diggin around in there. Whats the best bet to get it out? Last hing I want to do is accidently push it into the motor ar something like that.

    Thanks for the help!!
     
  6. Scottydoggs

    Scottydoggs Full Access Member

    Posts:
    1,020
    Likes Received:
    744
    Joined:
    Dec 16, 2017
    Location:
    NJ
    Name:
    Scott
    this guy says to thread a bolt into the screen, ive seen others use a pick to pop it out too.

     
    PNWMuseumman likes this.
  7. HiHoeSilver

    HiHoeSilver Away!

    Posts:
    6,137
    Likes Received:
    6,294
    Joined:
    Feb 28, 2017
    Location:
    Chicago
    Name:
    Nate
    I used this :

    20170409_185029.jpg

    Here's the best shot I have of where it is :
    20170409_191149.jpg
     
    jarydM and PNWMuseumman like this.
  8. PNWMuseumman

    PNWMuseumman Bow Ties Are Cool Supporting Member

    Posts:
    206
    Likes Received:
    142
    Joined:
    Feb 22, 2015
    Location:
    PNW
    Name:
    Chris
    Sweet thanks for the help both of you! I saw that video yesterday too, is it the same type of filter thing on the NBS? That guy is working on an 07, so I wasn't sure if GM changed it in the revamp of the model.

    Thanks again! You guys rock!
     
  9. Scottydoggs

    Scottydoggs Full Access Member

    Posts:
    1,020
    Likes Received:
    744
    Joined:
    Dec 16, 2017
    Location:
    NJ
    Name:
    Scott
    its in the same place. same job.

    hihoesilver has some good pics there.
     
  10. HiHoeSilver

    HiHoeSilver Away!

    Posts:
    6,137
    Likes Received:
    6,294
    Joined:
    Feb 28, 2017
    Location:
    Chicago
    Name:
    Nate
    No screen on my 06.
     

Share This Page