Search results

  1. CTUBS8732

    No high speed cooling fans?

    Changed temp sensor now only one fan spins in low mode and the other kinda spins. Prior to replacing, both wouldnapin in low mode. Only rear ac blowing how it should. Refrigerant is good. I'm stuck in a rut with this one
  2. CTUBS8732

    No high speed cooling fans?

    When driving it’s cold
  3. CTUBS8732

    No high speed cooling fans?

    Mines is 2005 Tahoe. Usually the fans are on high as soon as I start the truck with the AC on. Now high mode never kicks in even if the truck is idling for an hour. It ain’t overheating but also ain’t no cold air coming out the vents, just cooler than outside air. Refrigerant level is good.
  4. CTUBS8732

    No high speed cooling fans?

    I’m having this exact same issue. I just replaced the whole cooling fan relay fuse block with a fresh one cause the original had burnt prong ports. Thought I had solved the issue when I found out the ground was mounted in a bad spot due to shotty repair by body guy so I regrounded to a better...
  5. CTUBS8732

    No high speed cooling fans?

    Did that fix your issue with your fans?
  6. CTUBS8732

    Oil pan gasket replaced, still leaking... Might be rear main seal?

    I got quoted $500 for rear main and 250 for oil pan gasket. The guy at the shop raised the price on me. Ended up paying $1200
  7. CTUBS8732

    When your new shop puts on the wrong tailshaft seal

    What kind of grease do you put on the seal?
  8. CTUBS8732

    When your new shop puts on the wrong tailshaft seal

    Thanks for verifying!!! Ordering as I type lol
  9. CTUBS8732

    When your new shop puts on the wrong tailshaft seal

    Is your 05 4x4 or 4x2?
  10. CTUBS8732

    Replaced driveshaft u joints, now leaking output seal

    Is your truck 4WD? I’m looking for the same seal but in the reviews all I see is this is for 2wd. On the gm parts online it has 3 different seals to pick from but none say 4WD only 2wd. Just don’t wanna grab the wrong part when removing/installing . I only have 1 vehicle lol.
  11. CTUBS8732

    Please help!!

    Have you checked you under the hood fuse box for burnt ports? I replaced whole cooling fan relay fuse box cause I had a similar issue. Problem solved for me.
  12. CTUBS8732

    what are these connectors to?

    Cleaned it up and ran the part # that's exactly what it is. I'm trying to figure what the white one is.
  13. CTUBS8732

    1999 Tahoe/Lifter or Exhaust Manifold?

    I did this and had a few loose ones and 2 broken ones. Replaced the ones I could and used a repair clamp on the broken ones.
  14. CTUBS8732

    what are these connectors to?

    The black or white one?
  15. CTUBS8732

    P1133 code keeps throwing All new denso o2 sensors

    Bro they sell a clamp to fix the broken manifold bolt issue. I used one on the front driver's side bolt and last firewall bolt. Firewall bolt was PITA but the front one went on on 10 mins.
  16. CTUBS8732

    P1133 code keeps throwing All new denso o2 sensors

    I just cleaned my MAF and it cleared all codes on its own. I had B1S1 P1133 and no activity on B1S2. All of a sudden they're reading and codes are gone
  17. CTUBS8732

    what are these connectors to?

    Recently had shotty body work done and the guy who did the work didn't put back bolts where they needed to be not only that he also left connectors loose. I know 1 is for the fog light but the others idk. I've checked around and can't anything missing a plug in. 2 are plugged into some type of...
  18. CTUBS8732

    Suspension still stiff and jumpy after overhaul

    I wish. I trashed them. SMH.
  19. CTUBS8732

    Suspension still stiff and jumpy after overhaul

    Can I remove both torsion bars at the same time? I’m trying to locate some bushings for the lower control arms and wanted to do both at the same time. And would I need to do anything special in the process like alignment ect.
  20. CTUBS8732

    Suspension still stiff and jumpy after overhaul

    I’m gonna end up just buying the nivomats and selling my 5100s. They’re still brand new. Less than 500 miles on them. I’m glad I joined this forum. I should’ve a long time ago. When I had my P71s I was on crownvic.net learning everything.
  21. CTUBS8732

    Suspension still stiff and jumpy after overhaul

    I forget the rating of the tire but the max is 80psi. I’ve tried putting them at 35-45 but my gas milage goes to crap and I can feel the tires rolling over on themselves when taking turns, almost like a stumble. Also look flat lol. This is why I keep ‘em at 65.
  22. CTUBS8732

    Suspension still stiff and jumpy after overhaul

    The shocks on the front were about the same size. New ones were a bit longer. New Rear shock were noticeably smaller in diameter. Old ones were real fat.
  23. CTUBS8732

    Suspension still stiff and jumpy after overhaul

    I’m running 285/70/17s And aired up at 65psi. Max is 80 Cooper ATP Also, how do you do a z check? Never heard of it. And I didn’t level the truck.
  24. CTUBS8732

    Suspension still stiff and jumpy after overhaul

    Yup g65 and zw7 @Fless
  25. CTUBS8732

    Premier Smooth Ride

    That’s funny. I guess these bilsteins are not for me. I should of just went back with oem.
Top