J
Reaction score
10

Latest activity Postings About

    • J
      JohnnyA replied to the thread 10 psi when warm.
      Snowdrifter should I blow some air or pressurize some oil and put through oil passage?
    • J
      JohnnyA replied to the thread 10 psi when warm.
      This is the pid I used. Pid is off another forum. Typically my oil pressure is about half at the sending unit in comparison to the...
      • Screenshot_20220823-132629_Chrome.jpg
    • J
      JohnnyA replied to the thread 10 psi when warm.
      Thank you RAMurphy I will have a look see.
    • J
      JohnnyA replied to the thread 10 psi when warm.
      If the bearings were blown but all else was OK, I would expect a +/- linear increase up to the oil pump bypass valve opening...
    • J
      JohnnyA replied to the thread 10 psi when warm.
      This is what the oil pressure looks like under load
      • Screenshot_20220819-200035_Torque.jpg
      • Screenshot_20220819-200108_Torque.jpg
      • Screenshot_20220819-200137_Torque.jpg
    • J
      JohnnyA replied to the thread 10 psi when warm.
      Thank you all very much. I will look into the transmission build company. RAMurphy does your tranny guy have a number or company name...
    • J
      JohnnyA replied to the thread 10 psi when warm.
      I'm thinking that this is over my pay grade. Thanks Buggdave for all the info and thread. Do you belive a mod 4l65e will be as durable...
    • J
      JohnnyA replied to the thread 10 psi when warm.
      Thanks Rockola1971 I will look into the kits. I always wanted to rebuild a engine just not this one... i have to roll with it. I'm at a...
    • J
      JohnnyA replied to the thread 10 psi when warm.
      I will look online to see where and how to send the sample oil. I did just change the oil to 5w40 so I may run her for awhile. I have...
    • J
      JohnnyA replied to the thread 10 psi when warm.
      Confirmation snowdrifter, above is correct with machanical at the block outlet port closest to pump, and sending unit location value is...
    • J
      JohnnyA replied to the thread 10 psi when warm.
      There is no valve train noise. Some noise just started almost sounds like timing chain tensioner.
    • J
      JohnnyA replied to the thread 10 psi when warm.
      Thanks everyone! I removed the machanical gauge post filter and replumb the oil cooler lines. Cold start mid 35 at machanical gauge and...
    • J
      JohnnyA replied to the thread 10 psi when warm.
      Thanks oil pump was primed still didn't change anything except eliminate a variable in a horrible oil pressure rubik's cube
    • J
      I have a 03 denali with a lq4 LS 6.0 vortec engine that has 180,000 and low oil pressure 20 lbs on cold start at sending unit and no...
  • Loading…
  • Loading…

Forum statistics

Threads
120,214
Posts
1,660,195
Members
81,380
Latest member
tdebacker
Top