What connects there?

Discussion in 'Engine & Drivetrain' started by Bonestock, Mar 14, 2017.

  1. bottomline2000

    bottomline2000 Full Access Member

    Posts:
    985
    Likes Received:
    248
    Joined:
    Oct 21, 2009
    Location:
    Dallas, TX
    Name:
    Big G
    If your vent tube is missing or not connected from your valve cover to the throttle body u have unmetered air entering the engine. The computer can't compensate for it. Replace the tube and it should idle better. Right now ur computer is going crazy trying to adjust to air the MAF sensor can't measure. Long story short, you have a big vacuum leak.

    Sent from my SAMSUNG-SM-T377A using Tapatalk
     
  2. Bonestock

    Bonestock Full Access Member

    Age:
    34
    Posts:
    139
    Likes Received:
    21
    Joined:
    Sep 20, 2015
    Name:
    David
    The idle is smooth as silk and runs great. I will be fixing this today though. Maybe it will fix my vibration
     
  3. Bonestock

    Bonestock Full Access Member

    Age:
    34
    Posts:
    139
    Likes Received:
    21
    Joined:
    Sep 20, 2015
    Name:
    David
    Plugged it back in. Vibration is stil there.
     
  4. bottomline2000

    bottomline2000 Full Access Member

    Posts:
    985
    Likes Received:
    248
    Joined:
    Oct 21, 2009
    Location:
    Dallas, TX
    Name:
    Big G

    Nevermind that..just read u replaced plugs before the problem...check your ground strap from the firewall to the back of the motor. Make sure it's tight..also make sure they put the nut back on for the trans mount to the cross member. Can't see them making the same mistake twice.

    Sent from my SAMSUNG-SM-T377A using Tapatalk
     
    Last edited: Mar 18, 2017
  5. Bonestock

    Bonestock Full Access Member

    Age:
    34
    Posts:
    139
    Likes Received:
    21
    Joined:
    Sep 20, 2015
    Name:
    David
    It's also not shifted down to first a few times today. How long before I just ask this guy for a refund. I can't afford to keep leaving my vehicle there while they guess at the problem. I've lost all Confidence in this shop and I plan to communicate that on Monday.
     
  6. Bonestock

    Bonestock Full Access Member

    Age:
    34
    Posts:
    139
    Likes Received:
    21
    Joined:
    Sep 20, 2015
    Name:
    David
    Little update. Called the shop this morning. Tranny did some weird things over the weekend. Wouldn't shift into first etc. told me to meet him at enterprise. Renting me a vehicle until he gets mine right. Despite the hassle I can complain. He is doing the right thing I think.
     
    Tonyrodz likes this.
  7. Tonyrodz

    Tonyrodz Full Access Member

    Age:
    47
    Posts:
    5,094
    Likes Received:
    3,784
    Joined:
    Feb 16, 2012
    Location:
    Central Jersey
    Name:
    Tony
    Absolutely is. Hope he can get it all squared away for you.
     
  8. sumo

    sumo dn ʇǝƃ ʇuɐɔ & llǝɟ ı

    Age:
    37
    Posts:
    5,300
    Likes Received:
    530
    Joined:
    May 21, 2010
    Location:
    rhode island
    Name:
    ian
    So many variations that can cause it. But since you had trans work. It could be trans mount, u joints, underfilled trans, wrong fluid, something not reconnected like a connector or something electrical.
    Can you describe the nature of the vibration? Happen all the time? under acceleration? Certain speeds?
     
  9. Bonestock

    Bonestock Full Access Member

    Age:
    34
    Posts:
    139
    Likes Received:
    21
    Joined:
    Sep 20, 2015
    Name:
    David
    I was expecting to be put in a econo box for a week while he has my burb. Wrong. We went to enterprise and he rented me a 2017 Suburban for a week while he fixes mine. I can't say enough good things about Mike at Accountable Transmission. Despite the issues with my rebuild I feel like he is going to do whatever it takes. You have to respect that.

    The vibration occurs mostly between 40-50 mph but can be felt at times from 20-55. I'm fairly certain it's the balance on the converter. I climbed under it and checked the u joints and they felt right to me. Smooth highway and 70 mph it's super smooth. Just as smooth as this 2017. I told Mike all of this and we went for a ride. He is going to get to the bottom of it I'm sure.
     
    Tonyrodz likes this.

Share This Page